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       Welcome to LiBRARYSOFT!

Version 12  Build 948

Copyright © 1992-2025 www.librarysoft.com All rights reserved.

New Generation Technologies Inc.

Our help is designed to provide some of the most common issues

users run into as well as the latest information.

Online Help files are automatically updated. Direct Help download

links are provided with Upgrade links.

LiBRARYSOFT is upgraded every few weeks. There are 22 to 30

upgrades per year.

LiBRARYSOFT is upgraded every few weeks. There are 22 to 30

Upgrades per year.

Upgrades are optional. Due to the wide range of Libraries we work

with the latest upgrade may not necessarily apply to your Library

type.

Version 12 of LiBRARYSOFT

The new Interface contains the same programs as Version 10 but the
access is presented as a page rather than as a Toolbar. The program

can be reset to use the Toolbar.

Version 12 can use an updated Database Engine. A new Database

Connection window allows you to point to the Data file and to the

Library dll file.

The new Interface contains the same

programs as Version 10 but the access can

be presented as a page or toolbar.
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Installation and System Requirements

Installation can be by DVD or by download links.

Please Note: LiBRARYSOFTWeB, OPACinternet and
LiBRARYSOFTWeB Self-Circ are automatically installed but are
optional. Their ini files must be configured before they can be
used.

Operating Systems:

Windows  11, 10, 8.1, 8, 7, XP, ME and 2000, 2008, 2012, 2016, 2019

Networking LiBRARYSOFT requires a Server class of operating
system for the computer acting as the Server. Professional or
better for Windows 11,10, 8, 7 or XP.

Memory and space Requirements:

RAM and hard disk space requirements are minimal. The basic in-
stall requires around 50 megabytes on the hard disk. Ten thousand
records require around 7 megabytes of space. Note that data such
as cover images and pdf data will increase the size of the record.

Upgrade Files:

Unlike the Setup file the Upgrade install file will automatically
upgrade the applications without wiping the Data File.

Please ensure that you install the separate Firebird Upgrade
routine. It includes required additional files which will be loaded
into the UDF folder of the Firebird_3_0 folder.

Install options

You can install LiBRARYSOFT and LiBRARYSOFTWeB on a single
computer, on a Server, on a Cloud such as Dropbox, or on a Server
with a Web Static ip address.

Single Station - Licensing is per the Library so as many stations as
necessary can be used. We also license the Librarian to install and
use a copy at home for personal use. Note that the Import option
allows work at home to be imported into the Library computer
without interfering with Circulation.

Server - See the Network install instructions. The basic idea is to
install on the Server, install on the Workstations and point to the
data file on the Server. The Server can be Dedicated or used as a
workstation but it must have a Server Class of operating system.
Home Editions cannot be used as Servers. There are no network
licensing restrictions from LiBRARYSOFT, you can network to as
many computers as your Network can handle.

Cloud - LiBRARYSOFT can be installed locally but the Data file can
reside on a Cloud such as Dropbox.

Server with Web Static ip Address - Installation can also be on a
Network. The installation treats the Network as an Intranet. If
the Server has a Static Web ip address your library patrons can
search and use LiBRARYSOFTWeB from computer with a Browser
on the Internet.
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Should you require support…
If you require any assistance with the installation or use of LiBRARYSOFT,
please call our customer support department between 9 a.m. and 4 p.m.
PST Monday to Friday. Our fax lines and voice mail system are active 24
hours a day.  Or contact us by e-mail at support@librarysoft.com

NEW GENERATION TECHNOLOGIES INC.

720 Seneca St. Ste 107 #1053 Seattle WA 98101

Telephone +1 800 661 7112 Fax +1 206 299 9079
E-mail: mail@librarysoft.com

Getting Help
The Toolbar and new Page display both have a Help menu option.

The help includes online streaming videos, a regular help file along with
Help Tutorials.

Training Videos are loaded in with the Upgrade
We provide online streaming video access. Please do not

hesitate to request videos of interest.
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Installing LiBRARYSOFT Version 12 on a
Single Computer

0. Please log into the computer as an Administrator.

1. Use the link you were provided by email to download the
Setup file.

The file will go into your downloads folder.

Double-click to start the install and follow the defaults.

2. Skip this step and to go step 3 if you you are using LiBRARYSOFT
11 or 12. Earlier Versions of LiBRARYSOFT user Firebird 1.5.

Note that Version 12 can work with Firebird 1.5 by pointing the
data file and to the fbclient.dll file in the Bin folder of Firebird.

To use Firebird 3.0 please follow the steps below.

Check if the Firebird 1.5 is present.

Go to the Control Panel > Administrative Tools > Services

Check if Firebird 1.5 is listed. If it is please stop that service.

Uninstall Firebird 1.5 using the Control Panel (Programs and
Features).

Go to the Program Files (x86) folder and delete the Firebird 1.5
folder, also delete any gds32.dll and fbclient.dll files in the
Wndows System folders.
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5. Set sharing and permissions for the LiBRARYSOFT 12.0 folder. 
Not all of your users may have full Administrator rights to the
Computer. Users require full rights and permissions to the
LiBRARYSOFT 12.0 Folder as well as the
LiBRARYSOFTAutoCataloguing Folder.

Right-click on the LiBRARYSOFT 12.0 Folder and click Properties.

First you must share the folder and then set up Permissions

To view details  go to the main screen and click the Help Video by clicking

Info > Help > Help Videos > Install Videos >  Setting Permissions

When you have time you may wish to follow the steps below  so
users do not have to right-click to run as Admin.

Step 1: Locate LiBRARYSOFT.exe which is located in LiBRARYSOFT
12.0 Folder which is in the Program files (x86) folder of C drive.

Step 2: Right-click on LiBRARYSOFT.exe and click Properties.

Step 3: Click the "Compatibility" tab.

Step 4: Click the box to change to run as admin.

Step 5: Click Apply

3. Skip this step and to go step 4 if you have never installed
LiBRARYSOFT.

Remove or delete the empty LIBSOFTFB3.FDB file from the DB
folder of LiBRARYSOFT 12

Copy the converted LIBSOFTFB3.FDB our staff has sent into the
DB folder.

4. Use the link below to download the database engine Firebird
3.0.

http://www.librarysoft.com/Upgrades72/Firebird-3.0.2.32703_0_Win32.exe

After it has downloaded double-click on the exe to start the
install.

Select Classic Server when prompted

It is important to use the word masterkey as the password. It
should be in all lower case. Clicking Next will add masterkey
automatically.

Select “Run as a Service” when prompted.
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6. Starting LiBRARYSOFT.  

If Shortcuts are not available you can create one by going to the
LiBRARYSOFT Folder, right-clicking on LiBRARYSOFT.exe and
selecting Shortcut.

7. Registration: A new install will prompt you to register.

To register click Register > Register Offline and email us the
hardwareid code that appears along with a name for the Library.

We will send back the Registration Key.

7. Pointing to the Data File.

The Video Link below steps through pointing to the Data File and
the Library Client dll file.

To view the steps Click  Info > Help > Help Videos > Install Videos
> Pointing to the Data File

1. Click Local - The Remote Connection is used to enter a Static IP
address.

2. Browse to the Data File - The default location is within the DB
folder of LiBRARYSOFT.

3. fbclient.dll file - Browse to the local Firebird _3_0 folder.

Note that the address 127.0.0.1 is a loopback address pointing to
the computer itself.

If the data resides on a Server and you are installing on a
workstation, click Remote and enter the Server IP address.
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Installing LiBRARYSOFT Version 12 on a Network

1. On the Server.

Install and register LiBRARYSOFT Version 12 on the Server and
Install Firebird 3.0 on the Server (see Single Station Install).

The Server must have a Static IP address.

Port 3050 must be free for Firebird.

LiBRARYSOFT uses Port 7

Start LiBRARYSOFT

Click Setup > Administration > Client Registration

Click Listen.

2. Users require full rights and permissions to the LiBRARYSOFT
folder on the Workstation and to the LiBRARYSOFT Folder on the
Server.

See the Video Link below.

http://www.librarysoft.com/TRAIN/Client_SharingAndPermissions.mp4

3. On a Workstation

Install LiBRARYSOFT Version 12 on a Client Workstation.

Install Firebird 3.0 on the Workstations (see Single Station
Install).

Run by clicking continue, registering is not necessary, you just
want to confirm that LiBRARYSOFT is working on the workstation.

Close LiBRARYSOFT.

Start LiBRARYSOFTClient.exe

Enter the Static ip address of the Server, click Register.

If it does not register automatically please check Register Offline
and Click Register. Email us teh Hardwareid code that appears.
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If it does not connect or if Errors appear

1. Check that you are logged in as Admin for the computer.

2. Turn off Firewalls and Security programs that may be blocking
access.

3. The LiBRARYSOFT applications used must be registered.

4. Ping the Server to ensure that the two machines are
connecting.

Go to the Command Prompt on a Workstation and Type: PING
192.168.0.15  if the Server address is 192.168.0.15

5. Users need full shared rights and permissions to the
LiBRARYSOFT folder on the Server and the LiBRARYSOFT Folder
on the Workstation.

6. Both the Server and the Workstation must be using the same
Build of LiBRARYSOFT. The Build number and Version number are
shown in the staring Splash screen and can also be seen by
clicking the Info Button and clicking About.

7. Check that Firebird is running on the Server and on the
Workstation. You can check by going to the Control Panel >
Administrative Tools > Services.  Click Firebird to see whether it
is running. If stopped please start.

8. Check that the correct data and fbclient files are pointed to. All
the stations should point to the same path and filename. The
networking process goes to the computer with the  ip address
(Server) and follows the path shown to the data file. On a
workstation point to the local fbclient.dll file not the one on the
Server.

9. Firebird Port

Port 3050 must be free to allow Firebird access to it. If the Port is
in use please contact us for directions regarding configuration
changes.

10. A valid IP address must be used.

If you are unable to connect to your data file please check that
your server IP is within the ranges defined by IANA.

The Internet Assigned Numbers Authority (IANA) has reserved
the following three blocks of the IP address space for private
internets:

10.0.0.0 - 10.255.255.255 (10/8 prefix)

172.16.0.0 - 172.31.255.255 (172.16/12 prefix)

192.168.0.0 - 192.168.255.255 (192.168/16 prefix)

11. The message that the Firebird login must be changed
indicates that the word masterkey was not entered correctly as
the password when Firebird was installed. The simplest solution
is to stop Firebird as a Service, Uninstall Firebird and reinstall
ensuring that Next is click when prompted to have the system
automatically enter masterkey as the password.

12. The message that the remote connection is refused indicates
that the LiBRARYSOFT Folders are not shared or the permissions
are not set correctly. Sharing fairly simple but setting full
permissions does have a number of steps. See video link below.
Note that this applies to the LiBRARYSOFTAUTOCATALOGUING
Folder as well if you are  using AutoCataloguing.
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Video Help is loaded along with LiBRARYSOFT

To access click Info > Help > Help Videos

Installing LiBRARYSOFT Version 12 on a Cloud (Dropbox example)

Install on your computer following the Single Computer Install
instructions.

Put a copy of the Data file into Dropbox.

Start LiBRARYSOFT click Network click the top Browse.

Browse to the Data file in Dropbox.

Click Test Connection.

If it connects click OK.

Toolbar option Interface

The Version 12 install presents with the new Button Front Screen
Interface but you can change it back to the Toolbar layout.

To change to the Toolbar please follow the steps below:

Select Large

Check the Toolbar

Click OK.

Restart LiBRARYSOFT

Now when you double-click on the shortcut the Toolbar will
appear.
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Registering LiBRARYSOFTWeB

LiBRARYSOFTWeB registers automatically after LiBRARYSOFT is
registered.

A simpler way to network using LiBRARYSOFTWeB -
Intranet & Internet

We include LiBRARYSOFTWeB for a single library which can be
used on the same data file as LiBRARYSOFT. It is automatically
installed along with LiBRARYSOFT. For Intranet access you would
use the Static IP of the Network Server. For Internet access use
the Web Static IP provider given by your Internet provider.

LiBRARYSOFTWeB has a simpler interface and can be used as a
Web Application or used on a Network by treating the Network as
an Intranet which would not require internet access. All
computers connected to the Network would have instant access
via a browser and the appropriate username passwords.

For Searching the OPACinternet/intranet Module is included
would not require internet access. All computers connected to
the Network would have instant access via a browser. Users can
place Holds, Renewals and enter Review/Ratings for items. If the
library has a Static Web IP address it can of course provide full
internet access to Staff and Patrons.

The LiBRARYSOFTWeB.ini file in the LiBRARYSOFT 12.0 folder
contains path and port settings. You can open the file using
Notepad and edit the file to change settings. You can also change
some settings in the LiBRARYSOFTWeB start screen.

Running LiBRARYSOFTWeB

To start LiBRARYSOFTWeB right-click on LiBRARYSOFTWeB.exe
and choose "Run as Administrator"
Double-left-click on the LiBRARYSOFT Logo that appears.

The default browser will appear with the  Entry Screen of
LiBRARYSOFTWeB.

LIBRARYSOFT Staff will have provided a Username & Password.

If you would like to use LiBRARYSOFTWeB on the server for entry.
This step is not necessary if no entry is to be done on the Server.

To network to other machines the computer as the Server must
have a Static IP address and must have a Server class OS such as
professional or better.

To access the application from another computer please start a
browser and use the address below. Your Server  will have a
different static ip address and port number.
Example:  http://192.168.0.26:8082
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The LiBRARYSOFTWeB ini file

The LiBRARYSOFTWeB ini file has default settings pointing to the
installed data file. There is little here that you would need to
change unless you move your data file. In the example below the
location of the database has been changed and the name has
been changed. Such changes are optional.

DataBaseName=C:\DATA\StLeoSchool\LEO.FDB

Server installation

Note that the Server can be any windows OS pro edition such as
Windows 11 Pro or Windows 10 Pro or any Server Class such as
Windows Server 2012

1.       Install on the Server, follow all defaults.

2.       Register LiBRARYSOFT, this will automatically register
LiBRARYSOFTWeB and all the other modules.

3.       To start any of the web applications right-click and select
“Run as administrator”.

4.       LiBRARYSOFTWEB.ini within the LiBRARYSOFT 12.0 folder
allows you to point to the database, set the port number and
other settings.

5.       OPACinternet, SelfCirculation and KidsOPACinternet all have
ini files that can be edited as well.

They must however use a unique port number not used in any of
the other librarysoftweb applications.

6.       To start LiBRARYSOFTWEB on the Server Right-Click “Run as
an Adminstrator”

7.       On a browser use the ip address and the port number.
Example: http://192.168.120.15:3072
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The message entry here will appear in the OPACinternet Screen.

Renew, Reports, Recent Acquisitions and Holds can be
deselected in the OPACinternet.ini file. The Help link provides
information for users.

Registering LiBRARYSOFTWeBSelfCirc

The LiBRARYSOFTWeBSelfCirc setup process is similar to that for
LiBRARYSOFTWeB except it is in s separate folder. It requires a
separate port number.

LiBRARYSOFTWeBSelfCirc is automatically registered when
LiBRARYSOFT is registered.

Users enter using their Barcode and the last 4 digits of their
phone number.

Running OPACinternet/intranet

Please go to the LiBRARYSOFT Folder in the program files x86
folder > OPACInternet Folder.

To start OPACinternet right-click on OPACinternet.exe and choose
"Run as Administrator"

Double-left-click on the LiBRARYSOFT Logo.

OPACinternet.ini contains path and port settings. You can open
the file using Notepad. Edit the file to change settings. You can
also change settings in the OPACinternet start screen.

To network to other machines the computer as the Server must
have a Static IP address and must have a Server class OS such as
professional or better.

To access the application from another computer please start a
browser and use the address below. Your Server  will likely have a
different static ip address and port number.

If LiBRARYSOFTWeB is being used at the same time the Port
number for OPACinternet must be different.

Example:   http://192.168.0.26:8081/$/?DB
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Running Kid's OPACinternet

The procedure is exactly the same as for OPACinternet except it
must use a Port number different from that used by the other
Intranet/internet modules. A different port number is already
within the ini file.

Installing Service Versions

The great benefit of a Service Version is that the application will
restart even if the computer is accidently restarted.

OPACInternet service install

Go to the Windows System 32 folder
Right-click on CMD.exe and select "Run as an Administrator"
Type CD/ to clear
Type
CD Program files (x86)
Type
CD LiBRARYSOFT 12.0
Type
CD OPACInternet
Then type
OPACInternetService.exe /install
The message below will appear.
Service installed successfully.
Click OK

Start the Service
Go to
Control Panel > Admin Tools > Services
Scroll down to OPACInternet, click on it and click Start.

To view it on the server use the link below on any browser.

http://127.0.0.1:3062
or

or
http://127.0.0.1:3062/$/Start/?DB=LIBW

or
http://127.0.0.1:3062/$/Start/?DB=LIBW

To view it on any workstation change the 127.0.0.1 to the Static IP
address of your Server.
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LiBRARYSOFTWeB Service Install

Go to the Windows System 32 folder
Right-click on CMD.exe and select "Run as an Administrator"
Type CD/ to clear
Type
CD Program files (x86)
Type
CD LiBRARYSOFT 12.0
Then type
LiBRARYSOFTWeBService.exe /install
The message below will appear.
Service installed successfully.
Click OK

Start the Service
Go to
Control Panel > Admin Tools > Services
Scroll down to LiBRARYSOFTWeB click on it and click Start.

To view it on the server use the link below on any browser.

http://127.0.0.1:3064
or

http://localhost:3064

To view it on any workstation change the 127.0.0.1 to the Static IP
address of your Server.

Uninstalling a Service

Run Regedit or Regedt32.

Go to the registry entry "HKEY_LOCAL_MACHINE/SYSTEM/

CurrentControlSet/Services"

Scroll down to the service that you want delete right-click| and
select delete.

Restart the Computer.
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For Libraries that have purchased the Ms SQL version of
LiBRARYSOFT please see the install instructions below.

1. Download and run the Install file for the Ms SQL Server Version.

The screen will appear, click on Next follow all the default settings.

2. Go to your MSSQL Enterprise Manager, attach Libsoft.mdf
database to your MSSQL Server: Right Click on Databases, then go
to the menu and click on Action>All Tasks>Attach Database

Installing the MS SQL Version of LiBRARYSOFT

Click on the browse box to locate libsoft.mdf file ( the default location
is:  c:\Program Files\LiBRARYSOFT 12.0\DB\LIBSOFT.mdf )

Once attached the Libsoft data file should appear.

3. Please ensure, that the user of the program will has all rights to
read and write the “Libsoft” database.

4. Run Librarysoft.exe either from the Start button or from the
LiBRARYSOFT 9.0 folder (note that it can be run as a service).

5. You will be prompted with the “SQL Server Connection”  window.

6. Type your MS SQL Server name (note that this can be read
from the SQL Service Manager application).

7. Choose “Windows NT integrated security”  or “Use a specific
user name and password”.

8. If you chose “Use a specific user name and password”, type
SQL Server user name and password you are going to use.

9. Type database name on the server ( “Libsoft” by default )

10.  Click on “Test connection” button. If connection successful,
click on “Ok” button, if not, check your settings with SQL Server
Administrator and repeat steps 2-6 again with more attention to
details.

Please, note that the program is using “Microsoft OLE DB
Provider for SQL Server” for the connection with MS SQL Server (it
should be installed with correct MS SQL Server installation or can
be installed separately with the latest MDAC from Microsoft).

Note that there can be a Firewall Issue. Port 3050 must be
opened.

Users must exist as a login on the SQL server with DBO role to
the libsoft database
as per the example Andrei below.

Uses require full permissions and rights to the LiBRARYSOFT
folder on the server and the
LiBRARYSOFT folder on the workstation.

For Terminal Servers users in a group require the ability change
the LiBRARYSOFT registry settings.
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Multiple MS SQL Data files can be accessed from different
workstations.

In the example to the below we have two data files Libsoft and
Libsoft2.

After clicking on the Database Connection Icon the screen to the right
will appear.

On other workstation change the name from Libsoft to Libsoft2.

To verify the connection click the Test Connection Button.

Click OK to save the Change.
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OPACinternet - Ms SQL Version

There are three OPACInternet ini files within the LiBRARYSOFT 12
folder.

OPACInternet.INI, OPACInternetService.INI and
OPACInternetISAPI.INI

OPACInternet.INI applies to OPACInternet.exe which is an
executable to be run from the server, just double-click to run.

OPACInternetService.INI applies to OPACInternetService.exe, this
service requires a particular installation process. Please see the
Readme.

OPACInternetISAPI.INI applies to OPACInternetISAPI which
requires special installation see the Readme.

You will need to modify the INI file that applies to the
OPACInternet you wish to use. Note that you can certainly modify
all three but you only need to modify the one that applies to the
version you wish to use. As an example we will modify the
OPACInternet.INI file the process for the other two are similar.

Open OPACInternet.IN with Notepad ( Start button > Accessories
> Notepad ).

For each library add the following three lines as per the image
below.

[library_short_name]

Library = library_full_name

ConnectionString=Provider=SQLOLEDB.1;Integrated
Security=SSPI;Persist Security Info=True;Initial
Catalog=Libsoft;Data Source=WIN7PC-PC;Use Procedure for
Prepare=1;Auto Translate=True;Packet Size=4096;Workstation
ID=AT-3000;Use Encryption for Data=False;Tag with column
collation when possible=False

The modification you would make to apply to your library will be
to use the actual library name as library_full_name
and use Library as any name you would like to represent the
library in question.

For example if one of the libraries was called Winston Public
then you could have.

WP = Winston Public

The connection string is the same for each library.
The only two areas you would normally change as it applies to
your library is the name of the computer (server) which contains
the data and the name of the data file. For example although the
default name of the data file is Libsoft you may have changed it
to say library data in which place you would enter library data in
place of libsoft. The name of your computer may be WIN2008 in
which place it would replace WIN7PC-PC.

ConnectionString=Provider=SQLOLEDB.1;Integrated
Security=SSPI;Persist Security Info=True;Initial
Catalog=Libsoft;Data Source=WIN7PC-PC;Use Procedure for
Prepare=1;Auto Translate=True;Packet Size=4096;Workstation
ID=AT-3000;Use Encryption for Data=False;Tag with column
collation when possible=False
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Below is an example of an ini file.

[Options]
Port=8080
Library=NW Public Library

[Charset]
Charset=windows-1252

ConnectionString=Provider=SQLOLEDB.1;Integrated
Security=SSPI;Persist Security Info=True;Initial
Catalog=Libsoft;Data Source=WIN7PC-PC\SQLEXPRESS;Use
Procedure for Prepare=1;Auto Translate=True;Packet
Size=4096;Workstation ID=AT-3000;Use Encryption for
Data=False;Tag with column collation when possible=False

The links for your patrons that correspond to the example could
be placed on individual or central websites or given directly to
your patrons.

The links for each library would be the link below if you were
looking at the data from a browser on the server itself using
OPACInternet.exe

http://192.168.1.15:8080/?DB



© Copyright 2025        New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

28

Copy or drag OPACinternet.ini into the LiBRARYSOFT 11.0 Folder

Copy or drag Background.jpg into the wwwroot folder replacing the old
file of the same name

You will need to edit the OPACinternet.ini file to put in your own
computer information.
The ini file can be opened and edited with Notepad.

ConnectionString=Provider=SQLOLEDB.1;Integrated
Security=SSPI;Persist Security Info=True;Initial Catalog=Libsoft;Data
Source=NGTI-PC\NGTI2;Use Procedure for Prepare=1;Auto
Translate=True;Packet Size=4096;Workstation ID=NGTI-
PC\NGTI2;Use Encryption for Data=False;Tag with column collation
when possible=False

After you have made the changes Right-click on OPACinternet.exe
and select Run as Administrator.

The Window below will appear. Double - click on the LiBRARYSOFT
icon to start the Application.
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The first step is to get familiar with LiBRARYSOFT. However, as with
almost all software you need to be aware of the licensing restrictions
prior to installing.

1. We license a software purchase to the library, not to individual
computers, we define a library as a location in which circulation of
items occurs. Multiple libraries even within the same building would
require multiple licenses.

2. Please feel free to install LiBRARYSOFT. in as many computers as
you need within the building housing the library. You can install search
only stations off site at no charge.

3. We provide a free personal and home use license to
LiBRARYSOFT. for the single person designated as the Librarian by
the library. This allows the librarian to perform work at home should
they wish to do so. The smart import process of LiBRARYSOFT
allows such work to be imported into the library database without
adversely effecting any library operations which may have proceeded
while the librarian was at home. It will only add changes made by the
librarian.

4. We are generous with regard to any additional costs required (if
any) for any reasonable changes to the license restrictions. Please do
not hesitate to email or call us with any questions.

5. A common install scenario would be the installation of a Checkout
station, a Cataloguing station and several search stations within the
library. Additional search stations could be scattered within the
building or if OPACInternet/intranet is installed on the buildings file
server then every computer connected to that server will be able to
search the library database, place holds and renewals.

For advanced installation including network/internet installation of
LiBRARYSOFT please view the Append ix at the end of the manual.

LiBRARYSOFT. will install on almost any computer running Windows
from windows ME to the latest operating system including Vista,
Windows 2003, Windows 2008, Windows 2012, Windows 11,10,8.1,8,
7, XP, and ME.

The RAM required is minimal. If Windows runs, LiBRARYSOFT will be
able to run.

Hard disk space required is also minimal. A rough estimation of hard
disk space is less than 1000 bytes per record. As an example if the
library had 10,000 items it would require about 7 to 10 megabytes of
space. This is an exceptionally small amount of space given that
most computers today come with 500 gigabytes of space.

Data can be searched on the internet with computers using Windows,
Macintosh and Linux operating systems.

Ensure that the person installing LiBRARYSOFT. has full
administrative rights to the computer. Shut off all firewalls including the
Windows firewall prior to installing. LiBRARYSOFT. users require full
rights and permissions to the LiBRARYSOFT folder. Users only
require full rights and permissions to the LiBRARYSOFT folder on the
server and the LiBRARYSOFT folder on the workstation.

Getting Started

Licensing
The general idea, please see the appendix for details

System Requirements
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Videos can be accessed from the the Help menu.

Or, clicking the Online Help Videos will bring up a site
that brings up Streaming Links to the Training Videos.

Accessing Training Videos from LiBRARYSOFTAccessing Training Videos from LilBRARYSOFT

Help can be accessed by clicking on the Help Index menu option.

To access Help click the book icon on the tool bar.

Or, press the F1 key while within any LiBRARYSOFT screen.

The Contents tab displays all of the help information in a + -
tree type format.

Click on the plus button to have it expand into more headings.

The Search tab allows you to enter in a search term or phrase

For the latest help please go to:

http://www.librarysoft.com/HELPLIBSOFT/index.htm

New help information is added continuously please download the
latest help file from the LiBRARYSOFT support site and copy it into
your LiBRARYSOFT 12.0 folder.

Help Screens
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Accessing Training Videos from LiBRARYSOFTOverview of the Setting Up Process

There are default values already entered into LiBRARYSOFT which
can be edited to best fit your library.  The easiest way to begin is to
enter in a few records to get the feel of the system and then begin to
modify the settings as required.  Once you have an impression of how
the system works you may wish to modify some of the options below.

Optional Settings to modify:

0. Language:The default language is English but data can be entered
in multiple languages even on the same line.

1. Try different buttons and menu settings to see what all the options
are available.

2. Add Edit Loan Types settings to best apply to your items.

3. Add Patron Groups to identify your users if they are not already
listed.

4. Loan Groups to define borrowing periods unique to certain patron
groups and loan types. Say students have one set of borrowing
periods and you want instructors or staff to have another.

5. Edit/Add Subject Tree values. Enter in trees of subject hierarchy
that best fit your data, this is optional as subjects can be entered
directly.

6. Tree Photos or icon display. Assign photos or images to the tree
structure that best suit your subjects, under the Options select
Subjects.

7. Holiday Settings can be changed to set up dates that no fines
would be charged. This is not necessary if the library does not charge
fines and no fines are set in Loan Groups or Loan Types.

8. Under the Administration menu > User List and User Group
administrative staff can define access along with usernames and
passwords for your staff. The library may not wish all staff to have
complete access to all menu options.

9. If your Library was using Version 10 or later of LiBRARYSOFT it will
be necessary for our staff to convert your old database into a new
format. File less than 10 meg can be email as attachments. For larger
files a service such as Dropbox or Google drive can be used.

10. The Mail Client Setup can be set up to send any overdue or Hold
notices by Email.

11. If data resides on multiple machines the data can be appended to
the main data file by using the Import Database option.

12. Labels:
Item and Patron barcodes can be printed in advance of data entry or
afterwards.
Spine Labels and other labels can be printed as required.

13. Reports:
The layout of the Reports can be changed as required.
Print out reports as you need them.
General Custom Reports are reports that have been created using the
old Custom Report Generator. You can modify these reports.
Fast Custom Reports can be used to create customized reports over
any fields, in any order, with full control over layout.
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To begin using LiBRARYSOFT you need to first set up your library
name and loan types. Click on the Option icon and select Libraries.

You must enter at least the name of the library.

Click on Edit button to change an existing library name.

Notice that after you click on edit the Checkmark and X buttons turn
dark.

Type over or clear the name and type in you library name. The X button
can be clicked if you have not saved your edit or add and wish to
cancel.

The information entered in this screen can be used in reports, email
notices, and printed notices.

Click on the Checkmark icon to save the changes.

If you have more than one library.

Click on the Add to get a blank screen.

Enter in the library information.

To save the data click on the Checkmark button at the bottom of the
screen. The X button can be clicked if you have not saved your edit or
add and wish to cancel. The half-circle button is a refresh button.  It is
used mainly if you are working in a network and need to instantly
update all users with the change you just made. The system will of
course update itself so it rarely necessary to use this button.

Library Name Entry
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Accessing Training Videos from LiBRARYSOFTLoan Types

Loan types are used to define the items that you will be
entering into LiBRARYSOFT.

If your library has more loan types than are displayed please
enter them or edit  the existing names to best suit your library.

To edit a Loan type just highlight the Loan type and then click
on the edit button. The loan type will appear at the upper right,
now you can change the name of the Loan type to fit your
own. Once you are done, click on the check mark button.

To add a new Loan type click on the Add button and then
enter the loan type name into the blank entry box that appears
at the upper right of the screen.

The borrowing period of the items and how long the patrons
can borrow them are set up in the Loan Groups and Patron
Groups screen but at this initial stage of entry you do not
need to enter that information until you begin to enter patrons.

At the beginning stage of using LiBRARYSOFT you may wish
to enter in the loan types of the various types of items you will
be entering such as Book, Paperback, DVD... Note that you
can treat Book and Paperbook as the same LoanType it all
depends upon whether you would like to loan them out for
different periods of time or charge different amounts for
overdue fines. The field information however can be edited
later.

Loan Period: Duration an item can be borrowed.

Grace Period: If fines are charged it is the period in days that
no fines will be charged after the item is due.

Fine Cycle: The cycle over which fines are charged. A value of
1 would mean that fines are applied every day an item is
overdue. If the value was 2 then fines would be applied every
two days.

Max Loan Amount: Maximum number of items that can be borrowed.
Note that Loan Groups (see the chapter on circulation) allow you to
set different borrowing periods for different patron groups.

Fine Amount: The amount of fine that is charge over every fine cycle.
If the fine cycle is 1 then the fine amount is the amount that would be
charged every day.

Fee Amount: If you library charges fees you would enter the amount
charged to use the library. Note that the Circulation has a fee screen
to accept payment for fees.

Item can leave library: Check the box if the item is not a reserved
item and is allowed to leave the library.

Loan by hour: Check this box for items that are loaned on an hourly
basis.
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Patron Groups

Patron Groups allow you to define a name for a Group, an Expiry
Date, Hold Period and Loan Type limits, optional Payments and the
ability to disable a Group.

Looking at the Group Students. Select Patron Groups and choose
student as the group. You can now vary the expiry date of this group
so if this was a library for a junior college on semester you would
likely want this group to have borrowing privileges end at the end of
December assuming that now is the beginning of the term in
September. The hold period is the number of days an item will be kept
on hold for a patron of this Patron Group.

To make changes first click on the Edit button. Make the changes and
then click on the Check Mark button and the Database Refresh
button.

Note that when you make changes to date fields you can use the
Calendar that pops up or just highlight and type in the new
information.

You can of course add entirely new Patron Groups that may apply
such as STUDENT FULL TIME and add the appropriate information.

The Max All Types Loan Amount field defines the total number of items
of all Loan Types that can be borrowed by a patron belonging to the
Patron Group.

Loan Groups are linked to Patron Groups so as to allow you the most
complete control over what Patron Group can borrow.
If you do not define a Loan Group for a Patron Group the system will
use the Loan Type information in terms of borrowing terms. So if that
is sufficient you need not enter Loan Groups.

To assign a Loan Type to a Patron Group just click on the Loan Type
pulldown to select a Loan Type. Now enter in the information that you
would like to apply for that Loan Type for that Patron Group.

Loan Period defines how long the book can be loaned out for before
fines apply.

Grace Period defines a period after the book is overdue that no fines
will be charged.

Fine Cycle is the period over which fines are charged. Normally with
a Fine Cycle of 1 the fines are charge once per day. With 2 it would
be once per every two days.

Maximum Amount refers to the maximum number of items that a
patron from this Patron Group can borrow of this Loan Type.

Fine Amount is the amount of fine charged per each fine cycle. If no
fines are to be charged leave this amount to zero.

Loan Groups



© Copyright 2025       New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

35

Click on Add to add a new Loan Type to the Loan Group or Click Edit
to change existing settings for a Loan Type. Once you are done click
on the Check Box to save the changes.

Select the Renewal Period.

If the item should not leave the library deselect the check box.

If your library is loaning this particular item to a Patron Group by the
hour click on the Loan by the hour checkbox.
Hourly Loan Groups are often used for Loans of laptops or loans of
material that should have short term borrowing periods. Such periods
are also used for materials that will be used for studying for midterms
or upcoming exams.

The Expendable Checkbox should be checked if the item can be
discarded.

Loan Groups (continued)
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Adding Custom Fields

Some libraries may find the need for extra fields such Archival fields.
Another 13 fields can be added to LiBRARYSOFT. Search results will
display these fields in the OPAC module.

Go to the Options icon > Parameters

Click on the Custom Fields Tab

Click on the Add button

Enter the Field Name and size of field, click OK.

Data can now be entered for that field. In this example we
added only one field but we could have as easily added 13.
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Setting up Patron Barcodes
The process for setting up Patron Barcodes is similar to that for Item
Barcodes

If convenient it can be helpful to use a different range of barcodes for
Patron Barcodes than Item Barcodes. The reason for mutual
exclusivity is to allow the option of External Circulation. Your library
may never use this process so it is optional

External Checkout is an option that allows the library to check items
in and out using Wordpad, Notepad or any word processor.

If you need to change the appearance of the Patron barcodes go to
the Options Menu > Parameters > Click on Patron Barcode Mask tab
for Patron barcode changes.

Left/Right Alpha symbols - allows alpha symbols to be added such as
an I for item. Or words such as HighSchool.
This is not commonly used as barcodes are simply a one to one
identifier linking the item to the database.

Barcode Length - size can be increased, zeros will appear in front of
the current barcode to give longer length.

Use Follet Scanner Rules - This is to allow databases which had old
Follet barcodes to be able to use LiBRARYSOFT without purchasing
specially configured scanners.

Setting up Item Barcodes
Note that the basic rule of Barcodes is "The simpler the Better!"
Should your barcode scanner be stolen or go missing it is always
much easier to type a 4 digit number in rather than a 14 character
value.

Whenever you click the Add button in Catalog or in Patron Data a
new barcode button will be created one larger than the previous one.

If you need to change the appearance of the item barcodes go to the
Options Menu > Parameters > Click on Items Barcode Mask tab for
item barcode changes.

Left/Right Alpha symbols - allows alpha symbols to be added such
as an I for item. Or words such as HighSchool.
This is not commonly used as barcodes are simply a one to one
identifier linking the item to the database.

Barcode Length - size can be increased, zeros will appear in front of
the current barcode to give longer length.

Use Follet Scanner Rules - This is to allow databases which had old
Follet barcodes to be able to use LiBRARYSOFT without purchasing
specially configured scanners.
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Printing Item Barcodes
Barcode numbers are key to making automation easy.
The system requires an unique barcode number for every item, even for
those items that may never circulate.

There are three ways to get barcode numbers.

1. Purchase pre-printed barcode labels.

The benefit of such labels are their great durability, no label protector is
required. You can purchase pre-printed labels from LiBRARYSOFT.
Cost is $39 per 1000 labels, the labels can be ordered from our
website or by email or telephone.

To order we just need to know the starting barcode number, the library
name you would like to appear on the barcode and the quantity of
labels.

2. Printing barcode labels using LiBRARYSOFT before data
entry.

Click Reports > Labels

The Advance Label Print Screen is the first option
on the Pulldown.

Selecting Order by Barcode Number, this will
present the data in Numeric order. Order by
Barcode will be in Alpha order which is useful if
barcodes have alpha characters.

The Name of the library and the Telephone number
of the library can be added to the label by using the
Design Button.

2. Printing barcode labels using LiBRARYSOFT after data entry.

Click Reports > Labels > Item Barcodes

Leave the From and To blank will print all barcodes.

Selecting the Periodical Date range will all you to print items that were
entered over a certain date range. The entry process stamps the date
of entry into the Periodical Date field.

Or you can go to Reports > Labels > Customized Labels

Clicking the Add button at the bottom of the window allows you to load
Label formats from the New Labels folder in the LiBRARYSOFT 12.0
Folder.
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Patron Data can be entered individually ( Circulation icon >
Patron Data) or loaded in en masse (Admin icon > Ongoing Patron
Import). As with Item Barcodes the Barcode numbers for patrons
must be unique. You can even print Patron Cards (2.5 inches by
5.0 or 2 inches by 3.5) with a photo of the patron and the barcode
by going to Reports > Circulation Reports > Patron Pass.

With LiBRARYSOFT you can print Patron Barcodes with the name
of the patron at the top of the label, additional information could
be added by clicking The Design button to modify the label.

Printing Patron Barcodes
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LiBRARYSOFT gives you the ability to change the field names that
appear on the screen.

To change the field names you need to open the Caption.txt file that is
within the LiBRARYSOFT Extras Folder. If you have the install CD
you can access this folder by putting the CD into the drive and
clicking on Upgrades. Just drag the Captions.txt file into the librarysoft
folder on your computer (located in the program files folder of C drive).
Or, you can create your own Captions.txt file by just using Notepad.

Example:

For a Film library you may want to change Title to Film, Author  to
Director and Subject to Category.

Open Notepad (Start button of your computer > All programs >
accessories > Notepad).

Type in:

Author=Director
Title=Film
Subject=Category

Click on Save as and Save it as Captions.txt
Save the Captions.txt file into the librarysoft 12 folder of every
computer you wish the change to appear in.

Returning to the Original Settings:

To reset or clear the field names back to the default values first close
LiBRARYSOFT one computer you are using.
Delete the Captions.txt file and the Grid Columns.txt files from the
LiBRARYSOFT 12.0 folder. In Windows 7, 8, 10, 11 search the
computer for gridcolumns.txt and delete it after it appears in the
search results.
Start LiBRARYSOFT and all fields will be back to the default settings.
If this does not help please contact LiBRARYSOFT Support.

Changing the Field names for Catalog Circ OPAC Item and Patron Field Names
Below is a listing of the Item and Patron Fields.
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OPACInternet/Intranet Field Changes

This can also be done for OPACInternet/Intranet for search computers.

To do so put a copy of the Captions.txt into the Files folder that is
within the OPACinternet folder of the LiBRARYSOFT 12.0 Folder.

If you have multiple libraries such as the additional Library EBMATHS
you can set up such libraries with individual captions by Editing the
OPACinternet.ini file.

Add the line

Create the new Captions file for another library and save it as say
Caption2.txt

Edit the OPACinternet.ini file using Notepad to add the line below to
another library.

[Options]
ShowLogin=1
NotLoginedSearch=1
SetEmailAsPasswordForHolds=0
Port=3062
Library=EBMAT Elem
MessageFontName=Arial
MessageFontSize=10
MessageFontUnderline=0
Email=support@librarysoft.com
[Database]
Port=3050
DataBaseName=C:\DATA\EBMAT\EBMAT.FDB
Password=masterkey
UserName=SYSDBA
ServerName=127.0.0.1
FBClient=C:\Program Files (x86)\Firebird\Firebird_3_0\fbclient.dll
SQLDialect=3
[Charset]
Charset=NONE
CustomLogo=newgenlogo.JPG

[EBMATHS]
Background=Background.jpg
CaptionsFileName=Captions2.txt
DataBaseName=C:\DATA\EBMAT\EBMAT.FDB
FBClient=C:\Program Files (x86)\Firebird\Firebird_3_0\fbclient.dll
SQLDialect=3

Library=EBMAT High School

I
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Changing the Screen Layout - Patron EntryChanging the Screen Layout - Item Entry

The layout of the Catalog Basic and Additional entry
screens of the Catalog Module can be customized.

Click Setup > Options >Custom Catalog

As an example you could drag the screen to change the size and
move fields around

Click OK to save the change or click Cancel.

If you wish to go back to the original settings click Restore Defaults.

The layout of the Patron Entry Screen can be customized.

Click Setup > Options >Custom Circulation

As an example you could drag the screen to change the size and
move fields around

Click OK to save the change or click Cancel.

If you wish to go back to the original settings click Restore Defaults.
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Multilingual Field Names
You can change the field names to other languages as well as
enter the data in other languages. Add language settings using
the Control Panel (available for Windows 10, 8.1, 8, 7, 2008, 2003,
2000  and XP).

Example: Working with Hebrew:

Hebrew will have to have been set up as a language available
from the Windows toolbar.
Go to the Control panel of Windows > Regional settings

Languages - set complex script for left to right languages

click details

click add select Hebrew

click OK

Click Setup > Options > Regional options

select the Arial font

 select Hebrew under script, the default is western.

Restart librarysoft

Go to the Catalog Screen

On your task bar select Hebrew and you should be able to enter
in Hebrew script.

This presumes that Hebrew was set up via the regional settings in
the control panel.

Regional settings

Languages - set complex script for left to right languages

click details

click add select Hebrew  and click OK

This can also be done in OPACInternet by setting the Charset to
the correct setting for that language.

.To work with two languages:

Create files:

1) CaptionsFiles.txt should contain lines like:

<languge name>=<file name>;<Language Charset>

For example:

English = Captions.txt;1252

French  =  Captions2.txt;1252

Charsets for Language

Windows-1250 Central Europe languages: Albanian, Croatian,
Czech, Hungarian, Polish, Romanian, Serbian (Latin),

                           Slovak, Slovenian

Windows-1251   Cyrillic languages: Azeri, Belarusian, Bulgarian,
FYRO Macedonian, Kazakh, Kyrgyz, Mongolian,

                           Russian, Serbian, Tatar, Ukrainian, Uzbek

Windows-1252       Latin 1 languages: Afrikaans, Basque, Catalan,
Danish, Dutch, English, Faroese, Finnish, French,

                            Galician, German, Icelandic, Indonesian, Italian,
Malay, Norwegian, Portuguese, Spanish, Swahili,

                            Swedish

Windows-1253       Greek
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Windows-1254       Turkic languages: Azeri (Latin), Turkish, Uzbek
(Latin)

Windows-1255    Hebrew

Windows-1256       Arabic, Farsi, Urdu

Windows-1257    Baltic languages: Estonian, Latvian, Lithuanian

Windows-1258       Vietnamese

2) Create Captions.txt and Captions2.txt Both files should contain
equal number of lines for the same terms:

<original English term>=<new term>

For example for English and French:

Captions.txt: Captions2.txt:

Title=Title Title=Titre

Author=Author
Author=Auteur

Subject=Subject
Subject=Sujet

3) Copy all files to the folder where OPACInternet is located

Note that LiBRARYSOFTWeB is Unicode capable and can use
multiple languages even in the same field. No adjustment to
settings are required.
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Holidays
Click Setup  > Options > Holiday Settings

If your Library charges fines you can set up holiday dates over
which no fine payments will accrue.

To add a holiday or closure date just click on the Add button, scroll to
the right or left to find the date and click on it.  Enter a descriptive
name of the closure or holiday.

To save the change click on the checkmark button to post the data
and the refresh button to refresh the database with this new data.

Whenever a holiday is encountered the system will calculating an
overdue amount but will not charge for the days listed as Holiday.

Regular Weekdays and Weekends can also be added by clicking on
the Weekend button.
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Adding Items - Overview
Item Data can be added using a few different methods.

1. Direct Data Entry of Item Data
The Catalog Module can be used with the AutoFill button or if
newer items are entered that other sites have not yet Cataloged
you can click Add and enter the Title, ISBN, Loan Type. This
minimal amount of data can be later expanded by using the
AutoFill tab in the AutoCataloguing Module which can sweep the
database completing missing entries by using the ISBN to key into
library internet sites.

Within the Catalog Module there are a number of extra fields that
will not be available within internet sites such as Extra Subjects,
Reading Levels, TextStore (up to 300 pages of searchable text),
Videos, Sound and data links to applications such as Excel, Word
and Powerpoint. All this extra information need not be entered
does provide extra useful options.

2. AutoCataloguing
The AutoCataloguing Module allows staff to automatically add
new items including their barcode if one is on the item. If not the
system will automatically add a barcode. The acquisition process
also loads in an image of the cover of the item if one is available.
It can be used for Books or DVDs. The AutoFill option can be used
to fill in missing information for items that were previously
entered directly or from another system.

3. Ongoing Catalog Import
Using this option you staff can import delimted file. This allows
simple importing from Excel and other database applications.

4. LiBRARYSOFTWeB
Can be used at the same time as LiBRARYSOFT. It has a simpler
interface and a simpler AutoFill process which is different than
AutoCataloguing.

5. Using the Gateway
With the MARC module staff can import MARC data from
Publishers and other library systems.

Adding Patron Data

1. Direct Data Entry of Patron Data using the Circulation Module.

2. Ongoing Patron Import
Using this option your staff can import delimted files. This allows
simple importing from Excel and other database programs.
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Basic use of the Catalog Module
To start the Catalog Module Click Tools > Catalog
The screen below will appear.
To add a new blank record click on the Add button.

Enter the title of the item
and Secondary Title(s) if they exist. The Secondary title field is used
for items which contain multiple titles. Their authors may be added to
authors 2 to 4.

Use the library pulldown to select your library name.
Note that if your library is not present please go to Section 1 Adding
your library name. At minimum the library name must be entered to
process reports.

Select a loan type for your item.
 If the loan type of your item is not listed please go to Section 2
Adding Loan Types. Loan Types are used to define the loan period, fine
amount, grace period and periods of use.

Subjects
You can enter a subject directly or click on the browse button to select
an existing subject. To see how to edit and add or even import export
Subject Trees please refer the section of the manual called Subject
Trees and Pictures.

Call Numbers
The Call number entered can be Dewy, Library of Congress or any
format you may have developed. The call number field is linked to
LiBRARY MaP in terms of the ordering of items on the shelf. Note that
to cause an indent to appear within call numbers when printing Spine
labels you need to put spaces in the call number wherever you wish an
indent to be printed.

ISBN: Type or Scan in the ISBN number. With older books please
check that the value scanned is indeed the ISBN as the barcodes by
the ISBN in older items were often a publisher code rather than the
ISBN. EAN barcodes are usually the ISBN

There is much more you can enter including all the fields within the
other Tabs but if you just need to quickly add an item the critical fields
are Title and ISBN. The reason that entry of the ISBN is important is
that the AutoFIll option in AutoCataloguing can later be used to sweep
the database automatically filling in missing information.
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To enter the cover of the book or a representative photograph or
website page you can add one by clicking on the picture button.

Note that cover images are automatically when AutoCataloguing is
used directly and with AutoCataloguing AutoFill.

This brings up the screen to the right which allows you to select a
jpeg image that can be attached to the item.

Click on the Ok button to select the photo or drawing.

Adding an Image to a Record
You may also copy to the clipboard from any graphic application and
then click on the Paste Button if the image is satisfactory click on Ok
to include the image.  This is very useful for storing pages from
websites. You would first go to the website click on shift PrtSc (a
button at the top of your keyboard) and then go into LiBRARYSOFT
and click on the paste button to the right.
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Click the Additional. Tab at the top of the screen to continue or press
the F10 key.

Accession often contains the date that the library acquired the item
and the source of funding.

Collation is the physical description of the item.

Series refers to the name of the series of the item if there is one such
as the Hardy Boy Series.

Note and Subnote are usually used to describe the item.

Textstore is a useful field. You can paste in the entire content of a
book within it. All text stored
is searchable and may be selected from the search Website content
can be copied and pasted in.

Pdf files can be attached to a record, in this example it could be a Pdf
of the book itself or material relating to the  book. The content of text
Pdfs are searchable by LiBRARYSOFT.

The Additional Tab
The Value of OLE ( object linked embedded files) is that they can be
located anywhere on the network and when a user brings up the
record that has an OLE type link then they will bring it up via the
application that created it. So Word, Powerpoint, Excel and other files
can be started loading the data specific to the record automatically

The Status of an item allows you to define lost
or damaged items. It also provides information when
the item has been circulated. You can define your own Status values
by editing values in the Status entry screen.

The Status screen can be accessed under
the Options Menu (Setup > Options).
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LiBRARYSOFT has the capability to store and display a wide range
of media. Basically anything the Windows Media player can run can
be stored and referenced in LiBRARYSOFT.

If a record contains other media you will notice that the green play
button beside the media button is lit. If there is no media attached it
is a dull orange.

To add media click on the Media icon at the bottom of the screen.

A browse screen will appear that will allow you to move to a folder
containing the media you wish to store. The pull down to the right of
the folders indicate the types of file formats that can be stored and
displayed.

Choose the file you want to store and double-click on it.

Once a file has been selected you can try it by clicking on the play
icon to the right of the files.

Note that music files stored can be downloaded using OPACInternet
across the internet or across a network. The same applies to ebooks
(pdf stored files).

The end result is that after you select the media and post it you can
now click on the green button to see the media displayed.  Click on
the media player green button to run the player.

Note that for video type displays you can enlarge the image by
clicking on the box icon.

The extra media can be retrieved and viewed by patrons using OPAC.

The OPACInternet Module allows music files and ebooks to be
downloaded by patrons.



© Copyright 2025       New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

51

The MARC Tab displays the MARC code of a record that has been
loaded via AutoCataloguing or AutoCataloguing AutoFill or
LiBRARYSOFTWeB AutoFill.

The MARC Tab The TextStore Tab

TextStore can store up to around 300 pages of Searchable Text such
as the entire content of an Ebook.

TextStore content can be serached for by checking the box in the
OPACinternet search screen.
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Thousands of Research topics including website links can be added
to any record that has already been entered. This feature is useful for
libraries with items that require additional detailed information.

Steps to follow

1. Search for a record and retrieve the record.

2. Click the Research tab and enter a Related Subject.

3. Enter a value to represent the quality of item in terms of the
Subject.

4. A comment related to quality.

5. Enter a value to represent the quantity of the information relative to
the Subject.

6. Enter a quantity value to represent the amount of information
relative to the subject.

Adding Research Additional Subjects and Editing

Click the Plus sign to add a new subject.

Click the minus sign to delete a subject.

Click the backward forward icons to move through the subjects.

Click the Checkmark icon to save changes.
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The Reading Level information can be added directly by clicking Add,
entering the information and clicking the Checkmark icon to save the
information.

Adding Reading Level Information Tab Automatically Loading Lexile Data

The Ongoing Entry Screen can be used to automatically load in data
from Titles databases from Lexile.

Click the Checkbox beside Lexile Data Structure

This will automatically check the Update Box and the Update Key will
set to ISBN.

Select a Loan Type.

Click the Browse button and browse to the Lexile Titles Data File and
click the Start Button.
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Reviews Tab - Viewing and Deleting
Patrons can add Ratings and Enter Reviews using OPACinternet/
Intranet. Library Staff can review and delete Reviews and Ratings that
are not appropriate.

This process can also be done using LiBRARYSOFTWeB with also
has a Reviews Tab.

Adding Disposable Items
To create a disposable Loan Type, Click Setup, choose the Options
menu, Select Loan types, click the Add button

Enter the name of a disposable item, enter the borrowing information,
check that the item can leave the library, check the Expendable box.

Click on the Checkmark icon to save the information.

To add a Disposable Item go to the Catalog Module and click on the
Edit button and click on the Loan Type pulldown and select a
disposable Loan Type (Brochure). Enter the number of copies of the
brochure. Click on the Checkmark icon to save the information.
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Checking Out Disposable Items

To check out disposable items scan or type in the patron barcode
number or search and select the patron.

Enter in the number of copies you will be checking out ( you may have
a patron that is taking a number of the items to distribute to other
patrons or for an event ).
Scan or type in the barcode number of the disposable item

If you go to the Catalog Module and search for the disposable item
you will notice that the number of copies has decreased by the
number of items checked out.

Storing Websites and Content
Web sites access and information can be stored in LiBRARYSOFT.
Note that you can do this directly as per below or you can use the
LiBRARYSOFT Web Browser described on the next page. The Extra
Subjects Tab allows you to add hundreds of sites to record.

Click Edit and Paste or type in the website address (300 characters
max) and then press the Posting checkmark symbol. After doing so
the globe beside the website name will turn blue. Whenever you click
on the blue planet your browser will come up automatically and
display the website.

Web text content can be pasted into TextStore.
TextStore can store up to around 300 pages of content.



© Copyright 2025        New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

56

Adding the image of the Website
At times an image of a page of a website is useful. To record and
store that information you can use the Picture storage function. To
copy a page from a website you would do the following:

1. Bring up the website and move to the page you wish to record.

2. Windows has a built in option for screen capture, hold the shift key
down and press the Prt Sc button at right hand top of your keyboard.
The image of the screen is now stored to the clipboard.

3. Open LiBRARYSOFT if it is not already open and go to the Catalog
Module and to the record you would like to store the image in. Click
on edit and then click on the picture icon at the bottom of the screen.
The screen to the right will appear. Now click on Paste to store the
screen shot.

As the Catalog screen has an Enlarge Picture button this image can
be enlarged to full size for viewing at any time. Note that is also
accessible from the OPAC screen. It can be further enlarged by
clicking on the small box at the right hand top of the screen.

Adding Websites Automatically
LiBRARYSOFT can be used to store website addresses and
information about the website including a screen shot of any page
from the website. To make this process easier you can use the
LIBRARYSOFT Web Browser to automatically acquire websites and
website information. It allows you to search the Internet in the same
way that your regular browser does.

Click Programs > Web Browser

Although you can use any search engine for the
purpose of demonstration we have chosen Google.

Use the Search Browser to find your the website you are looking for.
Once you have found a website you wish to save click on the Add
Website button.
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Automatically it brings up the title of the website, the website address
and if you check the "Add to image" box a screen shot of the website
will be included.

You can click on the Subject box to select a subject from the Visual
Tree listing. Note that you can type in any subject information.

Copy and paste website content into the description field,
it will be put into the Textstore field which is searchable.

Click the OK button to save the information. Note that a barcode value
will be automatically assigned to the record.

To see the result of your entry go to Catalog Module and search for the
website you have just entered. You can search by any part of the
website name, subject or description information. Note that the Picture
button can be used to blow up the page of the website.

Patrons can click on the website icon to actually go to the website.

The description information goes into the TextStore field. This field can
store hundreds of pages of text.
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OLE file linking allows you to link a file to a librarysoft record. Clicking
on the OLE button after adding or editing a record will bring up the
screen to the right.

In the example below we are linking to a power point file. Notice that
"Create from file" and "Link" are both checked. The Browse button
was used to acquire the path to the Power Point file. By clicking on
the "Display As Icon" file a Power Point Icon appear as well.

Linking to Excel, Powerpoint and Word Files The end result is a numeric value that is automatically placed in the
Anystore field. Do not edit this value.
To access the link a user would just click on the Suitcase icon with the
arrow. Using Word as an OLE Link you can add hundreds of pictures.
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1. First note the folder on your hard drive or external device that
contains the Ebook.

2. If you are adding the Ebook to an existing title you must go into the
Catalog Module of LiBRARYSOFT and go to that Title. In this case we
are adding the Ebook of the Item "Black Beauty". Note that if there is
only an Ebook and no actual physical item you can just add the
Ebook and Enter a title after it has been added.

3. Click the Edit button at the bottom of the Screen.

4. Click the Ebook Button at the bottom of the screen.

5. Browse to the location of the Ebook on your drive or external device.

6. Click Open to load the Ebook.

Adding PDF files and Ebooks Now the Screen will display the path to the Ebook.

Click the Checkmark at the bottom of the screen to save the addition.
Note that after doing so the Ebook field on the screen will turn to a
number as the information is now stored within LiBRARYSOFT.
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Automatically Adding PDF files and Ebooks

Pdf's and Ebook Pdfs can be added automatically by Clicking

Setup > Administration > Add Ebooks

1. Select the Loan Type. For demonstration we have called the Loan
Type PDF but you can add a more descriptive Loan Type.

2. Allowing Searchability requires a little more space and will not apply
completely to items with graphics as the graphic images are not
converted to text.

3. Click the drive at the upper left and locate the folder containing the
Pdf files.

4. Select the files and click OK. The pdfs will automatically be loaded
into the librarysoft data file and will be accessible to Patrons for
download from OPACinternet and OPAC.

Adding/Editing the Subject Tree

Setup > Options > Subjects

Subject Trees are an optional way to create levels of subjects so
that your users can perform hierarchical Searches.
A Generic Sample Tree is included with LiBRARYSOFT

Trees can be imported and exported. Note that on your CD you
will find a Medical tree that can be imported as well as a religious
tree. Both are far more elaborate than the generic simple tree
included with LiBRARYSOFT. You can of course ignore the tree and
enter subjects directly or even delete trees (just click on a node
and click on the delete button).

The subjects entered are what make up the Tree-Type Search
screen and the Pictorial screen. Note that periods and other
punctuation values cannot be used.

The Subject Tree Designer screen appears.  Highlight a tree node
the tree to add or edit. Note that the + indicates more leaves
beneath.  Click on a plus to expand the tree. The plus will change
to a minus once it has expanded.

To edit tree node click on the node to highlight it and then click on
the Edit button.
To change the name of a Tree Node enter the new name in the
entry box.
Note: Only one unique name is allowed per Tree Node so if you
have Children already you can use Children's Books. Another
example would be Reptiles and Reptiles Pets as two different
Tree Nodes the former likely under Zoology and the latter under
Pets.

To add or change the photo or icon click on the Load button.

To change the colour of the Tree node click on the Change button.
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The load screen allows you to select from a list of images anywhere
on your hard disk or within the network.  You can also copy an image
and then use the Paste button to attach it.

To change the color of the Tree node click on the Change button.
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Subject Trees and Accelerated ReaderThe Color Change Screen allows you to select any of the colors
shown or create one of your own.

Click Add and type Accelerated Reader into the box that appears.
Note that this is just a suggested scheme for setting this process up.
You can restructure or redesign it as you wish.

Color is very useful in distinguishing nodes within the tree. To choose
a color click on the Change button and select.
Click OK.

In a similar fashion you can add Grades.
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To connect Subject Trees to an item start the Catalog Module and
choose a book or item.

Click on the box with three dots at the end of Subject 5.

For this example we can choose Grade 5.

The resulting tree information will appear in the Catalog record of the
item.

Clicking on the Additional tab you can add further AR information into
the Curriculum field.
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LiBRARYMaP Editor

The Map Editor screen lets you draw the shelving in your library.

Go to Setup > Options > Library Map Editor

If it does connect please click File > Connection

Click Local

Click the top Browse and browse to the address of the data file.

The default address is:

C:\Program Files
(x86)\LiBRARYSOFT12.0\DB\LiBSOFTFB3.FDB

Click the second Browse button and browse to the client file below.

C:\Program Files (x86)\Firebird\Firebird_3_0\fbclient.dll

Click Ok.

To add a call number range that
applies to a drawn figure click on
the Map button.
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Creating the Background for the Map

To Create a new Map click File > New Map

You can just click Ok to save the default size of 400 by 400 or modify.

Please note the size if you would like to add an image.

Now you can click the Draw button and enter text and use the draw

tools or you can add an image (see further down).

Click Ok and enter a name for the New Map, click Ok.
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Loading an Image into the Map

Rather than drawing the library shelving you can load an image
of the library and add text and draw upon it.

Use any graphics program to load and modify an image.

Restriction: Refer back to the size of the Map unless you
modified the size the default is 400 by 400 pixels.

To add an image first use the graphics program to copy the
image (example: Paint that is included with Winodws).

Select all and click Copy.

Go to the Library Map Editor > Edit and click Paste.

Now you can add text and draw on the image.

Text can be added to the Image. Click File > Save to save your work.
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Mapping Library Data into a Map

The great benefit of LiBRARYMaP is the ability to associate the

physical shelf position of an item to the Call number of an item.

After you have drawn the library you can overlay the image of the

library with a range of Call Numbers.

You can have multiple Maps, click File > Open to select a Map.

In the example below we have selected Map1.

Click the Map Tab

Click File > Save to save your work.



© Copyright 2025        New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

68

How Patrons would use the Map

The map can be selected by clicking the Change Map button. Users can access the map from OPAC (client server) or

OPACinternet (web version)

From OPAC they can click the shortcut or access from the page

display.
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Or after users search for an item they can click on Map in the results

screen.

OPACinternet Map Access

You can search by call number.

Or you can search for an item and then click the Map button.
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After clicking the Map button a red box will appear around the area

the item islocated in.
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1. For a quick first use take any relatively recently published paper-
back. Open the inside front cover and note the EAN barcode number
therein. Scan the barcode and if the book is from North America you
will see 978 followed by the ISBN number of the item. The number
978 is the country code.

2. Scan in the library barcode number of the book if you have attached
one. This is advantageous as it eliminates the need to later go back
and scan in this barcode number.

3. The cursor will now return to the ISBN number field to allow you to
scan in another ISBN number.

4. Click on the Search button after one or many ISBN scans.  Begin
with just a couple to start.

5. The search results will appear on the right hand side window.

6. If you are using a library system other than LiBRARYSOFT you can
save your data to a MARC file by clicking on Save to File.

7. The Load from file option lets you load in a data set you may have
scanned earlier and did not have time to transfer.

8. The Clear button cleans out the current search results so that you
can start anew.

9. Not all records will be found from the z39.50 sites you have
selected to search by. You can repeat scans later using different sites
or you can include the ISBN and barcode number to the transfer
process. The benefit of this is that you can fill in basic information in
the Transfer screen and dump it into the database. Later you can run
Data Auto Fill. This process can be set to fill only empty fields.

10. Click Transfer to move to the Add To Database Screen. Checking
the AutoTransfer will automatically bring up the Add To Database
screen.

AutoCataloguing
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Other Editing Controls

To edit a translated record first click on the Selector box to the left of
any record. The Checkmark icon will go from grey to black when a
record is selected for editing.

Now you can move your mouse into any of the fields of that record
and make changes.

This allows you to enter Title and Author data to records that were not
found by the ISBN Search (note that this presumes you checked the
"Translate Not Found" button.

If you have not scanned in the library barcode numbers of the items
you can choose a starting barcode number that will be automatically
assigned to translated items in consecutive order.

Similarly if Loan Types were not automatically assigned by MARC
translation you can assign a Loan Type for all of the items to be
translated. Note that the content for this pulldown list comes from the
Loan Types entered into your LiBRARYSOFT database.

Library names are retrieved from the LiBRARYSOFT database and if
the data is for a specific library you can load the name of the library
as part of the data.

Cancel all changes

Save changes made to the record

Edit the record

Delete the record

Navigate up and down thru the records

Post the record - not essential and only to be used if you need the
data to update to all workstations at that moment. The checkmark
icon will update the database but the Post command directs the server
to update all workstations immediately rather than have the automatic
update process refresh the stations.

To add the records to your LiBRARYSOFT database click on the "Add
to Database" button.

Edit Transferred Data
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Editing MARC Tags

To edit the MARC tags used to translate the data click on the Options
menu of AutoCataloguing and select "MARC Tags".

MARC tags are a universal method of describing the data contained
within a library record. Some z39.50 sites may be using different tags
than what the default settings are set to. If you are not cataloguing
according to library of congress call numbers you may wish to change
the MARC tag for call number to access the Dewey Call number.

Click on the Edit button.

Click on the Field pulldown and select Call Number.

Enter the tag number 082a

Click on the Checkmark icon to save the change.

Click on the X button if you do not wish to save the change.

Selecting z39.50 sites

To select one or many more z39.50 sites to search from click on the
Options menu and select Z39.50 Servers.

The Library of Congress is a default setting. To choose other libraries
click on the Order button to display those libraries currently selected.

Highlight the library you wish to select by clicking on it. In this case
Boston University.
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Click on the Select button to choose that library, or click
the Edit button, select the database and click the checkmark button.

The chosen library will stay highlighted in blue and you can now go
onto select another library.

Some libraries may require special port numbers, database engine
names as well as usernames and passwords. This information is
usually provided freely by the library but may require that you register
with that library via their website.

Running AutoCataloguing AutoFill

When you have an existing database you can use the Database Auto
Fill option to complete missing fields or to even replace poorly entered
data with Catalogued data.

This process will read the ISBN values within the database and go out
to the internet to retrieve the data and replace only empty fields or
replace then entire record.

Start AutoCataloguing (process is not available in AutoCataloguing2).

Select the Database Auto Fill Tab

Choose Replace all fields (this will overwrite all data within a record
that is found) or Replace only empty fields which will replace only the
non-empty fields of that record.

You can choose to sweep the entire database or only replace over a
range of Barcodes or over a Range of Dates. The Period Date is the
date the item was added. Note that the range is by alphabetical
Barcode order which is not the same as numeric order.

Clicking the Checkbox will fill the Call Number field with FIC followed
by the first three characters of the Author's Last name.

Choose a delay interval. A default period of 15 seconds is entered
automatically. If you have it at too low a value you will get non-hits as
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Loading data from an ISBN Listthe receiver sites will not have sufficient time to search at their end. If
you have fast internet access you can us a smaller value such as 5
seconds.

You can set a Fiction Call Number so that all Fiction items will have a
FIC before the first three characters of the author's last name.

Another option is to add the first three characters of author's last
name to the end of all Call Numbers.

Click the Start button and let the process run.

Note that you will need to set your computer not to time out,
otherwise the process will run only as long as your timeout period. To
change the period, go to the Control Panel > Power Options and set
the computer to never time out.

A list of ISBN numbers can loaded into LiBRARYSOFT using
the Ongong Catalog Import Screen. The AutoFill feature in
AutoCataloguing can then be used to fill in all the missing
information.

1. To acquire the list of ISBN numbers you can scan or type
the ISBN numbers into a Text file.

You can use any word processor but it is simplest to use
Notepad which is included with Windows.

Scan the ISBN values as a single column, see example below.
Do not include hypens or spaces. Note that older books may
only have 10 character ISBN values which is Ok.

In LiBRARYSOFT click Setup > Administration > Ongoing
Catalog Import
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1. Browse to the Text File.

2. Select ISBN as the Key rather than Barcode.

3. Deselect the Update Only box.

4. Select a Loan Type.

5. You can leave the Horizontal Tab setting as there is only one
column.

6. Click Start.
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After the file has been loaded go to Reports > Administrative Reports
> System Statistics

In our example we only had 4 ISBN values and the example database
was empty so the number of items is 4. These are however empty
records with only the ISBN numbers.

To fill in the missing information we can use the AutoFill feature in
AutoCataloguing.

Start AutoCataloguing from the Screen icon or the icon at the bottom
of the Catalog Window in LiBRARYSOFT.

Click the AutoFill Tab and Click Start.

Note that this will sweep the entire database.
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How to handle an ISBN List for a Range
To work with a range of ISBNs so you do not need to sweep the entire
database (large database can take time to sweep) first go to Reports
> Administrative Reports > System Statistics.

Note the highest barcode which in this case is 1012

Create your ISBN list.

Go to Setup > Administrative > Ongoing Catalog Import

Click Browse and browse to the ISBN text file.

Make the settings as per below.
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Click Reports > Administrative Reports > System Stats

Note the Highest Barcode Number which in the example is 1020.

Start AutoCataloguing and click the AutoFill Tab and check the Range
box and enter the from to Barcode Range and click Start.

How to handle ISBN records not found
Some records may not be found if the item has not been Catalogued
by the Searched library. As an example some publishers such as
Scholastic are not cataloged by Amazon.

To deal with these items you can sort them by going to
LiBRARYSOFT > Catalog Module

Click Advanced Search at the bottom of the Window.

Click Add in the Advanced Search Screen.

Select the Field "Title".

Select Condition "Less Than".

Value to Search "a".

Order by "Title".
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The Search results will display the items sorted by Title.

As the records not found by AutoCataloguing will not have a title those
records will appear at the top.

You can select those records now individually and fill in the information
directly.

Note that the columns can be dragged over to view fields, in this case
the ISBN has been dragged over to be adjacent to Title.

Double-clicking on a record will bring up the Catalog entry Screen.

Click Edit and fill in the Tile and Author along with any other
information you may wish to enter.

Click the Checkmark icon at the bottom of the window to save the
record change.
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Zoom Errors:
Can occur if AutoCataloguing was not able to register
VBZOOM.dll during setup process.

To register direct go to the Run option from the My Computer
icon.

Go to Start->Run

Then copy and paste in:

regsvr32 c:\Windows\System32\VBZOOM.dll

and click on OK.

Cannot Connect to Database

Under the file menu click Setup > Network >

Click Local and click Browse and browse to the FDB data file.

Click the Browse below the top one and browse to the
fbclient.dll file.

Click Test Connections to verify that it connects.

If the data is located on a Server, click Remote and enter the
ip address of the Server.  Select protocol TCP/IP. Click OK.

Socket Error 10061

Please click the Options Menu

Click Z39.50 Servers

Click the Order button at the bottom of the window.

This will sort the libraries that are set for searching in a blue
highlight and will be at the left top of the screen.

The are ordered by access.

Click Edit

Deselect that library by clicking the Checked box beside
"Database is selected for searching"

Click the Checkmark icon at the bottom of the window to save
the change.

Close that window and try searching for a record.
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Adding Data using the MARC Module
MARC is standard agreed upon format of data that can used to moved
data from different library automation systems.

This allows you to import data from libraries that have already
catalogued their data as well as from book publishers that can provide
a MARC data file along with the books you have purchased so that
the information regarding the book need not be typed in manually.

To start the MARC Module click Tools > MARC.

To begin a translation session first select the type of MARC.
US MARC is the default option.

Other options include MARC 21, Library of Congress (this format is
also used with older library systems), the National Library of Medicine
and U(K) MARC for British libraries.

MARC tables allow to you customize different sets of MARC tags if
you have data coming from various sources that use different MARC
formats so that you can customize the import process for each
format.

If the MARC data does not contain the barcode number you will be
applying on the book you can enter a starting barcode number. Only
purchased items with a MARC file or a previous data file will contain
the barcode information.

Select the loan type of the items that will be added.

Select the name of the library that the items will apply to if you are
loading data for multiple libraries.

There are two options for adding the raw MARC data.
You can either find the MARC data and do a copy paste
of the raw data or browse the computer for the MARC file.

Some systems that you may be importing your data from may have
indicated copies with the same barcode number. When in doubt
check the box that will apply a distinct barcode number for every
copy.

The Library of Congress button takes you directly to the library of
congress site so that you can use it to import data. Note that if you
have AutoCataloguing by LiBRARYSOFT you can import and load in
the data directly from any site using the Z39.50 protocol. This includes
most universities and large  public libraries and institutions.
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Editing MARC Tags

MARC tags are the identifiers that represent the data to be
imported. The tag 245a for example represents the title field.

The data you wish to import may be in a tag that is not
standard or different. If you are using Dewey call numbers you
need to have your Call number tag set to 082a. If you are
using library of congress call numbers it should be set to
050a.

You can change the fields that MARC data is loaded into by
editing the MARC tags that the system recognizes.  Click on
the MARC tags button within the MARC screen.

Click on the field you would like to change. Click on the
Delete button. Click on the Add button Click on the pulldown
to select the field, enter the new tag information (three digits
are required and a subtag) and click on the Checkmark button
to save the new information. Note if you put an * as the
subtag it will pick up all records with the same tag but differ-
ent subtags.

Aside from setting your Call number tag you will not usually alter
MARC tags unless you receive MARC data from publishers with the
books you have purchased. The standard MARC tags are already in
place but it is prudent to run a test run of the data first to ensure that
it is all loading, particularly the barcode information and call numbers.
If there is a problem you can always purge the data, change the
MARC tags and reload. Please do not hesitate to email
LiBRARYSOFT support with any questions.
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Adding Data using the Gateway
First select the Library of Congress from the pulldown.

If you have internet access you can go to the Library of Congress
gateway by clicking on the button or go to:

www.loc.gov/z3950/

The Gateway allows you to access the Library of Congress data or
access any of the libraries connected to the gateway.

Search from The Library of Congress
Select Advanced Search

Scroll down to select a library that may match your library then click
on the hyperlink to search.

Click on Tagged for display.

Select an index to search from. ISBN numbers are very effective to
search from.  Here we have selected Title.

After entering your search information click on the Submit Query
button.

The search results will be displayed; there may be multiple records,
select the one you wish and copy the text.
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Minimize the Explorer screen and then click on the Paste button.  The
text will display within the MARC screen.

Click on the Transfer button to translate the data.

Click Add to Database to save the record.

Batching Records

Records can be batched by copy/pasting separate records into
Wordpad or Notepad with a blank line between records and then copy
pasting the result into the blank left hand side of the MARC screen.

LiBRARYSOFTWeB

The same process can be used by the MARC Module in
LiBRARYSOFTWeB.
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Ongoing Catalog Import
If you have Tab, comma or other delimited files of some type you
can import item data using Ongoing Catalog Import

Click the Setup Button >  Admin icon  >  Ongoing Catalog Import
Click on the Browse button to access the file containing the data,
note the positions of each of the values in the file for example it
could be that the Title is in position 1, Author1 in position 2,
Author2 in position 3 etc.
The delimiter that separates each field can be chosen from the
pulldown below.
Deselect  he "Do not add..." checkbox to add new records.
Leave the Barcode button selected to key to the collection by
Barcode.
Click the Lexile Checkbox when loading update data from a Lexile
data.

Literary reflections Elkins, William R COLLEGE READERS 1976 McGraw-Hill
808.042
Radio control for models Warring, R. H MODELS AND
MODELMAKING 1974 G/L Tab Books
Frank Lloyd Wright: living architecture Ransohoff, Doris
WRIGHT, FRANK LLOYD Fundamentals of chemistry
Pottenger, Francis Marion CHEMISTRY 1976 Scott, Foresman
Mustang at war Freeman, Roger Anthony MUSTANG (FIGHTER PLANES)
1974 I. Allan The actor at work Benedetti,
Robert L ACTING 1976

Translation Values

To translate the text file above the settings would be as follows.

In the file above the
 title is in position 1,
the author in position2
the subject in position 3
the copyright date in position 4
publisher in position 5
call number in position 6
barcode number in position 7.

The position information can be entered into the Ongoing Catalog
Screen.

Prior to any import process it is always prudent to back up your data
file prior to importing.

Once the information is entered, click Browse to browse to the file.

Click Start to begin importing the data.

Note that a barcode number for each item is required in order for the
import to be processed. Barcodes must be unique.

Importing from Excel

Note that you can export Excel by first exporting Excel data to a tab
delimited file which can then be imported by using Ongoing Text
Import.

Example Text file below - Tab Delimited text file
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Circulation - Adding Patrons Overview

Adding Patron Data

1. Direct Data Entry of Patron Data using the Circulation Module.

2. Ongoing Patron Import

Using this option you staff can import delimited file. This
allows simple importing from Excel and other database programs.

Click Tools > Circulation > Patron Data

Patrons can be added by direct data entry into the Patron or the data
can be imported via Excel or Delimited files. In particular the Ongoing
Patron Import option is useful for periodic loads during the year as it
will update all patron information Most administrative programs will
provide a Patron Export option.

Click the Add button.

Enter the patron name, last name first. No comma is required
between the last name and first name.

A barcode number will be automatically added. You can type over the
number added with any number. The max number of characters is 20.
We recommend 4 to 9 numbers. If your barcode scanner ever goes
missing it is very tedious to type in 20 characters.

It is essential to enter a Patron Group by using the pulldown.
Click the Checkmark icon to save the data.
Minimal patron data entry is the name, group and barcode number.

Circulation - Adding Patrons
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Defining Patron Barcodes

You can run LiBRARYSOFT by using the default settings. However if
you are planning to ever use external checkout and checkin you will
need to have the item barcodes and patron barcodes mutually exclu-
sive. Item barcodes and patron barcodes should not match.

You can define the general appearance of the barcode by going to the
Options icon > Parameters > Patron Barcode Mask.

If you would like to change the appearance of the patron barcodes go
to the Options icon click on Items Barcode Mask tab for item barcode
changes.

Left/Right Alpha symbols - allows alpha symbols to be added such as
an I for item. Or words such as HighSchool.
This is not commonly used as barcodes are simply a one to one
identifier linking the item to the database.

Next New Barcode number - displays the next barcode number to be
used. Note that it must be larger than any number presently in the
system. You can see the current largest barcode by going to Reports
> Administrative Reports > System Stats.

Patron Name: Enter Last name First.

Date of Birth: If the data has been entered by import the date will
automatically be set to the year 1899.

Telephone: The last 4 digits of the number are used as password for
access to renewals for patrons using OPACInternet.

Email Address: Users with an email address can have notices
including overdue notices emailed to them.

Room: Some custom reports have the report keyed by room number.
This would allow an instructor to receive an email or paper printout of
all the overdues or items borrowed by students within that room.

Alert Info: This can contain circulation related information about the
client such as "Special Assistance required". Or details regarding the
contact person.

A photograph of the patron can be added to the record. This can be
done via import using Excel or directly using the Picture button.

Click on Picture and browse to the location of the image.

Patron Data Fields
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Click Setup > Administration > Ongoing Patron Import

In some libraries a significant number of patrons are added
continuously or have their addresses change. The ongoing import
process reads a comma delimited file containing the patron information
and update patron data. The comma delimited file can be obtained
from the institution's administrative program. Note that the import
process described is very similar to that used for Ongoing Catalog
Import.

Restriction: Importing by this method requires that the data
contains patron barcode information.

In the case of renewing Student informaion with the instance of a new
school term or Semester you can either Purge all Students along with
their History (Setup > Administration > Purge - set range from 0 to
999999999)

Or you can check the box in the screen to Mark Patrons as not in the
System and a "Not in System" alert message will appear in their
record. And wil appear if someone trys to check out with their barcode.

Ongoing Patron Import

Step 1.

Save your patron data file that is coming from the other application in a
comma delimited format.

Most administrative type programs allow an export option to tab
delimited, excel, comma delimited or some other option.
If it can be opened in excel you can save it in a comma delimited
format from excel or Tab delimited. Open Office and other spreadsheet
applications allow for similar export options.

Step 2.

Note the name and the location that you use to when saving the
delimited file.

Step 3.

Note down the relative position of each relevant field within the file. That
is what is in the first position before the first comma, the second, etc.

You may wish to open it with excel to more easily see the positions.

Suggestion: If you do open it in excel delete any empty columns or
columns with data you do not wish to add to avoid confusion.

Step 4.

In LiBRARYSOFT click Setup > Administration > Ongoing Patron
Import.
Use the pulldown to select the Patron Group  Students if you importing
Students rather than Staff.
Use the next pulldown to select the type of delimited file you are using
such as Tab or Comma.
Check the "Mark Patrons..." box only if you want to patrons not in the
import to have a "Not in System" appear in their Alert box.

On the next page s an example of what such a file may look like.

Note the positions of each of the values in the file.
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Step 7.

Click Start, you can verify the load by going to the Circulation icon and
clicking on the Patron Data tab and searching for patrons or you can
go to Reports > Administrativ Reports > System Stats and see the
change in the number of patrons.34242,Smith,John,51,North, Block,987398

34243,Jones,Joe,54,North, Block,987399
34244,Urkins,Charles,61,North, Block,987391
34245,Wilke,Bob,32,North, Block,987392
34246,Yarro,Jay,77,North, Block,987393

Position 1 in the example to the right is Patron Barcode.
Position 2 in the example to the right is Patron's last name.
Position 3 in the example to the right is Patron Barcode.
Position 1 in the example to the right is Patron Barcode.

Step 5.

Enter the name of the file or browse to the delimited Text file.

Step 6.

Enter the field positions into the applicable column.
The columns 1, 2, 3 refers to the consecutive content to be
loaded into the patron file.

For example:

34242,Smith,John,51,North, Block,987398

The translated result using the screen to the right would fill
the fields in the following way:

LocalID = 34242

Patron Name= Smith John

Address= 51 North Block

Barcode = 987398
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Basic Circulation
To Checkout items first click on the Circulation icon.

As the Circulation screen appears it automatically displays the
Checkout Screen and the cursor is positioned to the patron barcode
field.  You can now wand in the barcode of the patron which will then
display their information or you can use any of the following three
search methods:

Alpha Search:
brings up patrons in alphabetical order.

Photo Search:
allows you to select a patron by photo and name.

Full Search:
allows for all search options.

Once the patron information appears you can now enter in the item
barcode. This can be done by wanding in the barcode of the item or
performing a search.
The item information will appear including the due date of the item.
You can now checkout another item. When all of the items that the
patron wishes to borrow are checked out a receipt can be printed out
by clicking on the printer icon.

For the next patron you can either move your mouse to the patron
barcode field and wand in a new patron or tab up to that field and then
search or wand in a new patron.

Checkout Button
As most barcode scanners are set to automatically supply an Enter
Character at the end of their scan there is no need to click on this
button. It is for someone checking an item out without a scanner.

Holds List Button
Displays the items this patron has on Hold

External Checkout Button
Applies to a checkout that was done with a word processor. This
could have been the case for textbook checkout done by a teacher at
a computer without LiBRARYSOFT installed.

Receipt by Email
Checking the Send by Email will send the receipt by email rather
than print it. To Set up Email go to the Admin Icon on the Toobar >
Email Client Setup. Check the box beside MAPI on that screen if you
are using Outlook otherwise enter the email information.
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Some libraries such as resource libraries only mail out their items and
never have their patrons come into the library, in this case it is very
useful to be able to print out a mailing label rather than the usual
receipt.

Print Options:
The Print Receipts Screen allows you to print the last Receipt or print
all the receipts of the day (convenient for a copy or if you are mailing
all items out at once).

Report Formats:
You can choose to have reports formatted in the conventional Name,
Title, Due Date presentation or Name, Address for mailing. The Design
button allows you to alter the format and fields.

Output:
Send the Report to the Screen and or Printer (Print)
To a PDF file (Print to PDF)
To a RTF file that any word processor such as word can read.

Receipt Printing - Options

Use the conventional Design screen to change the layout of the report/
label as well as the fields.
To view access to the fields click on the View Menu > Toolbars > and
check Edit, Format, Standard.

To change a field, click on the field (notice the field name appear to the
right of DBpipeline) and select a new one. To add a field just copy and
existing field, paste the field, now you can click on field pulldown and
pull down a different field.

Design
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Checking In Items

Select the Check In Tab.

Wand in the item to be checked in or click on the Search icon to
locate the item.

After the item is checked in the number of days the item is overdue is
displayed.

Hold displays
If a hold is on the item the Message box will display information about
the patron that the item is on hold for.

CheckIn Button
As most barcode scanners are set to automatically supply an Enter
Character at the end of their scan there is no need to click on this
button. It is for someone checking an item out without a scanner.

External CheckIn Button
Applies to a checkin that was done with a word processor. This could
have been the case for textbook checkout done by a teacher at a
computer without LiBRARYSOFT installed.

To view the history of items borrowed by the item click on the History
tab. The date indicates when the status changed.
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The Items Borrowed Screen displays items that have been borrowed,
are overdue and items currently borrowed.

Text in red display indicates overdue, text in blue indicates items
currently borrowed but not overdue and text in black indicates items
borrowed and returned.

Click on any items you wish to renew and click on the Renew button.
Note that if the All Items button is chosen all items would be selected.

Items Borrowed

You can use a barcode reader and a text file to create files of items
checked in or out.

Checking out Externally

For a check out file use a portable reader and Word or Notepad. Wand
in the Patron barcode number followed by the items checked out by
that patron. Then wand in the next patron barcode followed by the
items checked out by that patron. What should result is a column of
barcode numbers. Save this file as a text file. Copy this file into the
library computer and click on the External Checkout Button to
process. A browse window will appear that lets you point to the text
file you created.

Checking in Externally

For a check in file use a portable reader and Word or Notepad. Wand
in the items checked in one after the other. What should result is a
column of barcode numbers. Save this file as a text file. Copy this file
into the library computer and click on the External Checkin Button to
process. A browse window will appear that lets you point to the text
file you created.

Checking in and out with a portable reader

To check out enter the patron barcode number followed by the items
checked out by that patron. To check in you must wand in a barcode
value of zero followed by any items that are to be checked in. If
patrons check out after checking items in follow the regular procedure
of entering the patron barcode number followed by the items they
check out.

Checking In and Out Remotely
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Putting Items on Hold

To add Holds or remove Holds click on the Hold tab.

Enter the barcode of the patron.

Search for or enter the barcode of the item you would like to place on
hold. If you typed in the barcode number of the item rather than
scanning or searching for the item then the Put on Hold button will
appear. You can click on it or press the enter key to place the item on
hold.

A display of the item on hold will appear when the item is checked in
or checked out.

Holds will automatically be removed once the hold period of the patron
group the patron belongs to has passed.

The Patrons Holds Report (under the Report Icon-Circulation Reports)
allows  you to mail hold information, create a pdf or email the hold
notice directly to your patron.

Reserves are to be place by Patrons that wish to limit the circulation
of an item for a period of time. It could be to reserve certain books for
a class to allow everyone access. Or, for a corporation that needs
continuous access to the material for certain projects.

To place an item on Reserve first click on the Reserve Tab.

Click on the Search icon to find the item(s) you wish to put on
Reserve.

Once you have found them you can select them and then either enter
the date that the Reserve should begin in the date pulldown or click
on it to bring up the Calendar and select the date.

To complete the Reserve process click on the Reserve button.

When the item(s) no longer need to be on Reserve simply click on the
Un-Reserve button.

Putting Items on Reserve
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Search Replace Patrons
As per the Catalog Search Replace for items this process also exists
for patrons. Click on the icon will bring up the screen below.

Click on the pulldown to select the field you would like to change data
over. Enter the text that you wish to change and the new text and then
click on the Replace button. An example would be to change the
content of the Dept field with another name say as Grade 11 changing
to Grade 12.
Note that if you are doing multiple grades start with the second from
the top grade and work down. So if you were changing grades from 8
to grade 12 you would start with grade 11. Change the grades from 11
to 12, then do grades 10 to 11, 9 to 10, 8 to 9.

Renewing Items
Click on any items you wish to renew and click on the Renew
button. Note that if the All Items button is chosen all items would be
selected.

Click Setup > Options and select Parameters

Click on the Renew tab.

Click on the checkbox if you would like the library to be able to renew
items that are overdue.

How often a Renewal can be applied to a Loan Group or Loan can be
set within the Loan Types and Loan Groups Screens
under the Options Icon of the Toolbar.

Allowing Overdues with Renewals
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Items History

To view the history of items borrowed by the item click on the History
tab. The date indicates when the status changed.

The Search Button allows you to search the History by Title or
Barocde.

To add fines click on the Fines Tab. This will bring up the screen to the
right.

To add the fine information that you see on the screen you must click
on the Add button. This will bring up the screen below.

Fines, Adding and Paying

If the Add and Pay buttons are not shown you will need to add those
options to the Staff User by going to Setup > Administration > User
Groups

Within the Add fine you can add fine information such as that within
the screen below. A similar screen exists for paying fines.

Selecting a fine displays all the fine information.

Fines can be deleted and edited in case of errors.
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Some libraries charge fees monthly or annually. To set up library fees
go to the Options icon on the Toolbar and choose Patron Groups.

Select a Patron Group and assign a monthly or annual Fee for use of
the library.

To pay the library fee  Click on the Circulation Icon on the toolbar, click
Patron Data and click on the icon to the right of the Fees Owing box.

Note that Fees are not fines but rather are the optional annual or
monthly fees required to use the library. Not all libraries charge fees for
use. Expiry can be set per patron group or individually

Patron Fees

Paying Fees

Modifying the Receipt

Clicking on the Design button allows you to modify the layout and
presentation of the Receipt.

Click on the Options icon and select Parameters

Click on the Renew tab.

Click on the checkbox if you would like the library to be able to renew
items that are overdue.

How often a Renewal can be applied to a Loan Group or Loan can be
set within the Loan Types and Loan Groups Screens
under the Options Icon of the Toolbar.

Allowing Renewals

How many Renewals
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Setup > Options > Patron Group

Create a new Patron Group called Disabled (could be any name). Click
on the Disabled Checkbox.

To prevent a patron from borrowing items, go to the Circulation Module,
click on the Patron Data Tab, click on Edit.

Change the Patron Group of that patron to the new Patron Group

Disabling Access to a Patron

To save data entry time the Repeat Patron Button allows you to
duplicate a patron entry. So if a family of five wished to join the library
you could repeat the record of one person and then just edit the name
on four of those records rather than re-typing the data five times.

Repeating Patron Data
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OPAC for Single Station or Networked StationsSearching with OPACs

There are four different OPACs available with LiBRARYSOFT which
can be used separately or at the same time. OPAC, OPACinternet/
intranet, Kids OPAC, Kids OPACinternet/intranet.The great benefit of
OPACinternet and Kids OPACinternet is that after installing on the
Server no installation is required on the Workstations as they connect
via a browser. Internet access is not required as it can treat the
network as an Intranet.

1. Client Server OPAC - Includes Regular, Advanced, Pictorial, and
Tree-Type  searching. Plus LiBRARYMaP and Patron access.

2. Standard OPACInternet/Intranet Searching. Install on a server or
web server for Intranet or Internet searching. No installation required
on search stations, across the network or internet.

OPAC can be accessed from the Toolbar but rather than allow your
patrons access to the Toolbar it is better to simply create a shortcut
from the OPAC file in the LiBRARYSOFT folder.

To create a shortcut right-click on the OPAC file within the
LiBRARYSOFT folder and click on Shortcut. Drag the resulting
shortcut onto the desktop screen.

Click on the Regular text to bring up the Regular search screen.

Use the pulldown to select the method of searching.
Four options appear, you choose any
one to search your data with the term
entered.

Enter a search term to look for.
Click on Everywhere if you would like all of the fields listed searched
or click individually on the fields you would like searched.

Use the Order by pulldown to order the resulting browse screen by
almost any field.



© Copyright 2025        New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

102

A browse screen of hits appears. You can double-click on the item
you wish to look at or click it once to highlight and click on the Details
button. This brings up the same screen as that the data was entered
into. Data displayed cannot be edited or changed.

Advanced Searching

Click on the Advanced text to bring up the Advanced search screen.

Click on Add to start a search statement.

The search screen allows you to modify three pulldowns. The logic,
Field and Condition.
The results can be ordered by a wide range of
fields.

Enter a search term to look for.

These conditional sentences can be layered to as many as you like.
When you are complete click on the Ok button and then the Search
button from the main screen to search.

Network button: This button will display the database connection
screen so that you can install only OPAC on a work station and link it
to the database without installing all of LiBRARYSOFT.
(See network installs - refer to installs manual)

Network Connection
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Visual Tree Searching
Click on the Tree-Type text to bring up the Tree search screen. This
is a very useful addition to LiBRARYSOFT's search capabilities. This
function alone combined with the Catalog Module is worth far more
that the regular price of LiBRARYSOFT.  The depth capable will
become more apparent as you use the subject pulldowns in the
Catalog Module and this search screen.  LiBRARYSOFT allows you
to edit and create your own trees which could be used for any search
related function including management hierarchy charts.

There is a great deal going on in this screen. The centre root of the
tree is LiBRARYSOFT. The mouse passing over any leaf to the tree
displays the subtrees of that particular leaf. In this case the mouse
was moved over the Gardening box which then displayed instantly
the subtrees and the image associated with the leaf.

Double Clicking on any item will display any subitems moving the
item more to the center. Another double click will collapse all the
subitems.

To search you would just Right- Mouse click on any leaf of the tree.
This will display the selection box beside the leaf.

Browse will display all items in the database with the leaf name as a
subject.

Regular and Advanced Search as per usual.

Collapse with remove all subtrees attached to a leaf.  Collapse all
will remove all leaves displaying only LiBRARYSOFT in the centre.

Expand will display all subtrees attached to a leaf. Expand all will
display all the leaves of the entire tree.

Dragging: Put your mouse on any leaf and hold the left button down.
You will drag the entire tree pulling with the leaf you have chosen. This
is very helpful in working with large trees.The Scale Trackbar allows you to increase and

decrease the distance between items

The Centering Speed Trackbar lets you change
the speed at which items move within the Tree
display.



© Copyright 2025        New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

104

Pictorial Searching
Pictorial searching is linked to Tree-Type
Searching. The photos or icons attached to
the leaves in the tree appear as icons here.
The hierarchies follows that of the trees.

To search you would just Right- Mouse click on any leaf of the tree.
This will display the selection box beside the leaf.

Browse will display all items in the database with the leaf name as a
subject.

Regular and Advanced Search as per usual.

Double-clicking on an icon: Put your mouse on any icon and
double-click. This will bring up the icons associated with the subtrees
of the icon you clicked.

The two screens of the original entry appear.  No fields can be edited
or deleted. Clicking on the Picture button will enlarge any photo or
website page that was attached. Clicking on Additional will bring up
the second screen of entry.

The Additional screen brings up TextStore (content of a website or
large amounts of text) as well as other fields. To view any media that
was attached click on the green play button to bring up the media
player. To go to the website of the address entered click on the blue
planet icon.

Using the Search Result
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Using LiBRARYMaPLiBRARYMaP Editor

The Map Editor screen lets you draw the shelving in your library.

Go to Setup > Options > Library Map Editor

The A symbol allows you to enter in a name for the shelving.

To add a call number range that
applies to a drawn figure click on
the Map button.

To draw the area of shelving that
applies to the range click on the
dotted line to enter a Call Number
range.

In the OPAC module your patrons would
click on the Map icon to
search using the Map program. Users can
move through the map
with a mouse and see call number ranges
displayed. Or, in any
search a map icon is displayed that will
show the location of the
item searched for.

To add a photo to your library map just use a graphic program to open
your photo and under the edit menu of your graphic program click on
copy. Now go to Library Map Editor and under the edit menu click on
paste.
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OPACinternet/intranet
This Module allows Staff and Patrons to search from across the
internet if it is used on a Server with a Static Web address. It can also
be used on a network with no Internet access by treating the Network
s an Intranet. Or it can be installed and used on a single station with
no Internet access.

To Start OPACinternet please go to the OPACinternet Folder within
the LiBRARYSOFT 12.0 Folder and right-click on OPACinternet.exe
selecting Run as Administer.

Serveral fields can be Edited.
The Port number to be entered, it must be different from the one used
The name of the Library can be edited.
The Charset can be changed to allow for Multiple Languages.
Renews from OPACinternet can be allowed or blocked.
The color of the Bar in OPACinternet can be chosen.
A message can be entered to appear when the application starts such
as "All books must be returned to the Library by Friday."
The font of the message can be changed.
The Change button is used to save the changes.

Double-click on librarysoft icon to bring up a browser on the computer.

Patrons can access the Search screen from any computer networked
to the computer acting as the server. It's uses the Static IP of the
Server and the Port number.

The Help button provides directions for use of the application but most
of the functionality is fairly straightforward.

The website of Library and the Contact Page of the library can be
accessed by patrons.

A logo image can be put at the upper left of the screen. The logo file
must be put into wwwroot folder which is in OPACinternet folder of
LiBRARYSOFT 12.0.

The OPACinternet.ini file must have the name of the logo.
You can open this file using Notepad or any word processor.
The line below must be in place.
 CustomLogo=home_logo.jpg

An Image can also be added, store the image in the Files folder within
the OPACinternet folder.

The image file must have the name: MainImage.jpg
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Search Results allow Patrons to select the item.

The Rating/Review displays an average of Ratings followed by the
number of Reviews. Patrons can enter a review by entering their
barcode number and the last 4 digits of their telephone number.

Inappropriate Reviews can be deleted by Library Staff in the

Review Tab of Catalog in LiBRARYSOFT or
LiBRARYSOFTWeB.
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Using the Search Result Screen

Detail Screens can be selected by clicking on the Info Bar.

Basic Screen

Reading Levels

TextStore

Additional

Media

The OPACInternet/Intranet Module can be used by your patrons to
search from across your network by treating it as an intranet using the
Static IP address of the Server. If the Library has a Web Static IP
address your patrons can search from the Internet.

The SYNC program can be used to update your data file on our
servers directly or automatically.

The SYNC program is accessed by going to the Admin Icon of the
Toolbar.

You will need the following information from LiBRARYSOFT Support in
order to fill in the SYNC screen. Please email or Telephone
LiBRARYSOFT Support.

Host ip address
Port number
Database Name

You can then choose to Synchronize the data file immediately by
clicking the Synchronize Database button or you can click on the
Check box and have the file updated automatically daily.

Note that your computer will need to be left on in order to
automatically SYNC.

The Remote Database option is to be used for Libraries that are using
LiBRARYSOFTWEB. It will allow changes entered
by LiBRARYSOFTWEB be added to the LiBRARYSOFT
data file.

OPACinternet/intranet

Synchronize Remote Database
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Printing Labels

Click Reports > Labels

Click on the pulldown to display the labels and click on one to select.

Although you can print Labels over a range by many different fields it
is usually more useful to select an order and later specify a range if
necessary.

Libraries that have not used Synch before will need to send a copy of
their data file to our staff
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Clicking on the print icon does not print the item directly. It sends it to
a preview screen that allows you to define a range within the preview
screen; page range, current page or all pages.

Note that the order of Barcode is not the same as the order by
Barcode number as the former is an alpha ordering and the latter is
numeric.

Printing Options

You can print Labels directly to the printer after viewing a preview or
send it to a Pdf file or print to Word file. If your Library does not have
Word you can use Wordpad which is included with all Windows PC's.
Or you can download Open Office and use their free open source word
processor.

To provide greater versatility particularly when printing only a few labels
within a sheet you can send the print to an .rtf file (word) and edit the
sheet in Word or wordpad prior to printing.

To edit the layout and content of the label click on the Design
Tab.

To turn on full editing capability click on the View menu click
on Toolbars and check the Format and Edit options.

Now you can edit the content of the screen. Note that you
may need to expand your screen to the right to see the new
box that appears if you click on a field.

Note that the font and font size can be changed by pulldowns.

Clicking on the Preview Tab will display a printable screen.

Changing the Label Layout
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Margins and Tabs
To further tweak the layout of a label you can affect the margins and
column sizes.

Click on Design > File menu.

Choose Page Setup

Click on the Margin tab to alter the Margins.

Click on the Layout tab to change the column sizes.
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Spine Labels -auto indent
The Spine labels and Shelf list labels display the Call numbers in an
auto-indented format. The indenting occurs when a space has been
placed in the call number.

Example: 484.2 CLE will print with an indentation since there is a
space between the 2 and C

484.2
CLE

The default is to provide 5 lines of call number information.

If you require 6 lines of Call number information please do the
following:

Open the label/report you wish to modify
Click on the Callno5 field (note it could be any field).
Click on Copy under Edit
Click on Paste under Edit
Move the new field into position
Click on the field pulldown and select Callno6.
Under the File menu Select Save As and name your new label or
change the existing one by using the same name.

If a new name has been used the Save will list the new label under
label pulldown that appears when you click on the label icon.
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Saving Labels/Reports to a File

The process below is for Reports > Labels

Select the Label you would like to save to a file.

Click Design

Click Template to expand
the options.

Click the pulldown next to
Save To and select
stFile

Then go to File > Save

To save the Label as a file close the Design screen and click
Save to File.
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Using ReportsPrinting Barcode Labels
Before Item or Patron Entry

Select this label option to print barcode labels before the data has
been entered. You only need specify a range and print. Printing in a
range that matches the number of barcode labels on a sheet is
always a good idea. So if there are 30 labels on a sheet you may
wish to print a range of 1 to 60 if you wanted around that number so
as not to waste labels.

After Item or Patron Entry

A common way to get data in quickly is to use the AutoCataloguing
module to acquire say 30 records if there are 30 labels on a sheet of
labels and then print that sheet of labels. The title appears on the
label so they are easy to match to the appropriate item.

The simplest way to print is to leave the range from and to blank,
Choose order by Barcode Number (not Barcode unless you need an
ordering by alphabetical).

A preview of the print screen will display on the screen. You can move
back and forth through the pages if you have already entered and
printed some items.

Click the Reports button

A very useful report for getting a general snapshot of the database is
System Statistics from Administration Reports

This information also appears on the front screen when
LiBRARYSOFT Version 12 starts.
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Patron Reports
Select Patron Reports by choosing the Reports > Circulation Reports
> Patron Reports

Two different layouts are available for Patron Reports.
Condensed and Short.

Select Short

Click on the Design button

You can send the Report to the Printer,
to a Pdf or to a .rtf file (word, wordpad, notepad).

This report displays the field names at the top and the content below.

Clicking the Field will display the Field selector.

The selection pulldown that will allow you to change the fields.

Save changes under the File menu.

Reminder Report

This Report allows staff to send Patrons Reminders when Items are
due.
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Overdue Reports
Reports > Circulation Reports > Overdue Reports.

Overdue reports can be printed out as a list or sent as a notice. By
clicking on the Don't print if email exists you can avoid unnecessary
printing.

Note that label cost can be saved by lining up the address of the
patron so that you can use envelopes with a clear address section on
the envelope.

The Order By pulldown is extremely useful as it can make the Range
from unnecessary for most printing.

If you select an Order by say Room or Level you can group the
printout for your patrons so that they can be easily distributed.

The Days Overdue selector allows Staff to Report on Items before they
are Overdue by choosing a minus value such as -2 days.

Modifying Overdue Notices -Short and Long
Text can be modified within an Overdue Notices reports.

Click on the Design Tab

Right-click on the Textblock you want to modify

Click on Lines

Change the text
Go to File and click on Save.
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Fine Reports
Select Reports > Circulation Reports > Fine Reports.

Note that in order to charge overdue fines you must have set up fine
amounts and periods over which patrons would be charged in the Loan
Type and Loan Group Entry Screens ( Setup > Options > Loan Type,
Loan Group ).

The Select and Sort by allows you to restrict a range for printing. The
Range From and To assume a less than and greater than range. Note
that Capital letters have a different order than lower case. For example
the Range From Pic to Piz is not the same as pic to Piz and a
different result will occur.

The Print Icon does not print immediately. It displays a preview screen
that permits you print all pages or list a page range.

Fines can be displayed as a list or as a letter.

The Fines List report displays the items that fines apply to, an
explanation for the fine and a sum of all fines owed.

To modify the layout and to change the fields displayed click
on the Design Button. To edit fields click on the View menu of the
Screen that appears and select Toolbars, choose Edit. Now when you
click on a field the name will appear below Data Design Preview, use
the pulldown to change fields.

The Notice Text in Fines Notices can be edited by right-clicking within
the text and selecting Lines.  Go to File > Save to save changes.
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Patron Pass Reports (Library Cards)Notices Report

Select Reports > Circulation Reports > Notices Reports.

The Notices Reports allows you to send a notice to all of your
patrons or only a select range by using the Select by options.

To modify the layout and to change the fields displayed click
on the Design Button. To edit fields click on the View menu of
the Screen that appears and select Toolbars, choose Edit. Now
when you click on a field the name will appear below Data
Design Preview, use the pulldown to change fields.

Once you begin typing in the Notice Text the Save Notice button
goes live. You can save the notice so that it can be used in the
future again.

Select Reports > Circulation Reports > Patron Pass/Library card.

The Patron Pass Report (Library Card) allows you to print library cards
in two pre-defined sizes. Note that these are templates and you can
modify the size to best your requirements.

Clicking on the Design button will display the layout and fields used in
the card.

The Card can be modified by changing field names, layout and
content. To affect changes click on the View menu > Toolbars and
choose Edit, Standard and Format (if you would like to change font
and font size).
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Patron Holds Report
Select Reports > Circulation Reports > Patron Holds Report

The Holds List will provide a list of current Holds.

The Holds Notice are notifications of Holds to Patrons.

Emails can be sent to Patrons with Email addresses.

Click Design to edit the Library Card.

Click Preview to view.
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Patron Receipts
Select Reports > Circulation Reports > Receipt Reports.

Patron Receipts can be provided to patrons after they checkout items.
A listing of all receipts can also be printed at the end of the day
should the library need such a listing.

Two different formats can be used, the more common is the Name,
Title Due date, however a shorter form with just the name and address
can be used. Both can be modified.

Clicking on Design will display the fields and layout of the report. It
can be modified by changing field names, layout and content. To
affect changes click on the View menu > Toolbars and choose Edit,
Standard and Format (if you would like to change font and font size).

To change the width of the report or physical printing size to best fit
your printer click on the File menu > Page Setup
The Margins and Paper Size tabs are the most useful in changing the
size.

Click Preview to view Receipts.
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Loan Types Report
Select Reports > Circulation Reports > Loan Type Report.

Loan Type Reports display the Loan Type and the number of items of
this Loan Type Checked out by a patron.

Collection Circulation Graphic Report
Select Reports > Circulation Reports > Loan Type Report.

Click the Pulldown to select the type of Transaction.

Select Fiction, Non-Fiction or All and select a Date Range.

The Report will display Bar Charts of the counts per day.
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Day Activity Report
Select Reports > Circulation Reports >Day Activity Type Report.

The report will display the activity of a range of dates.
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Catalog Reports - The Shelf Barcode List

To run the Shelf Barcode List Report click on Reports > Catalog
Reports > Shelf Barcode List

Two different reports can be run, Condensed or Short.
Click on the Design button to make changes.

The Order By pulldown allows you to select the order that the data will
be sorted by.
Note that Order by Barcode is not the same as Order by Barcode
Number.
Some libraries have barcodes with alphabetical characters in their
barcode. Sort by Barcode will sort the data by Alpha.
Sorting by Barcode Number will sort the data numerically by the
internal numeric value assigned to the record. This internal value may
not necessarily match the Barcode.

The Shelf list Reports are useful in that the content can be easily
modified.
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Items Borrowed, History, Reserved, Holds
To run the History Reports click on Reports > Catalog Reports >
Items borrowed, History, Reserved, Holds

The Report can be Ranged using the pulldown and bounded by
start and end dates. The layout and fields displayed in each
report can be changed by clicking on the Design button..

The Range From and To is a less than and greater than search.

Example: If Patron Name was selected and you wished to only
find items borrowed by Alisum Sally you would select Patron
Name from the pulldown and use the range of Alh to Alj
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Collection Circulation Statistics

Click Reports > Catalog Reports > Collection Circulation Statistics

The Report can be Grouped by the Fields below over a Start Date
and End Date.

Patron name
Room
Department
Zip
Age
Patron Group
Title
Call Number
Subject
Author
Loan Type
Publ Date
Barcode

Item Count Report

This Report can Group and Count Items by Subject, Author, Loan
Type or Series.
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Collection Statistics GraphicsCollection Circulation Statistics

Reports > Catalog Reports > Collection Circulation Statistics
Graphics

Leaving the Range From To blank will bring up all the Rooms in
this Report over the selected Date Range.

Reports > Catalog Reports  > Collection Circulation Statistics
Graphics

Status is the current state of the item such as On Shelf, Borrowed,
Lost, Damaged.
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Customized Label Reports

Reports > Reports > Customized Labels Reports

Changes that were made in Windows 10 updates have required some changes to our Labels and Reports a new Report Generator.

There are new folders in your LiBRARYSOFT 12.0 Folder called FAST LABELS and FAST REPORTS.

To add these new Labels and Reports select Reports > Fast Custom Labels Reports.

1. Click Add
2. Select a Table

3. Browse to the Label file
4. Enter a Name

5. Click Add
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Your new Label will now be listed in the pulldown.

Leaving the From To blank will select all items.

The Order by has two levels. In the example above the labels will appear in order by Call Number and for those items with the same call
number they will appear in Title Order.

                        Print will display the results on screen but there is a Printer icon at upper left to allow you to send the results to a printer.

                                The results will be saved as a pdf file.

                                The results will be saved as an rtf file which can be read by Word or Wordpad.
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To modify or create a new Label or Report click Design.

Fields can be dragged into the Report.

Be sure to go to File > Save As to save your work as you will notice the file name at the top of the screen is untitled. This is in order not to
allow you to accidently alter the original report or label by accident.

Number of Columns
along wit Margin
positioning can be
changed by going to
File >Page Settings.
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Reports > Fast Custom Reports

Select an existing Custom Report

Go to File > New Report

Customized Reports
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Click the Data Tab

Left-Click IBDAC Database
Move the mouse to the empty area
to the right and right-click draging
out a small area.

Do the same for IBDAC Query
Icons will appear.

Left double-click on the icon

The Connection screen will appear.

Enter the locatio of the data file.

The login username is: SYSDBA

The password is: masterkey
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Click the Query Icon.     Enter an SQL statement. The example above selects all the Catalog Items.

Click the Page1 tab above (next to Code and Data) to get the screen below.

Drag a field from the query list to the right into the MasterData area.

Click File > Preview to see the result.
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Backing up Data

To access Backups click the user icon on the tool bar
and select Backup Database.

You can back up to any folder on your network or to an external
device such as a zip drive.

Note that some networks and security programs may prevent the
LiBRARYSOFT backup program from functioning. We do not
recommend you spend a great deal of time trying to solve this
problem but suggest instead to use any existing backup programs
already in use within your network or purchase an inexpensive
third party backup program that is compatible with your security
system.

The path of your data is automatically entered.
Use the Browse button to find a destination for your data, add the
extension .fbk to the name you use.
To start the backup process click on the Start button.
The Verbose Output screen will display the backup process as it
runs. When it is complete click on the close button.
Note: Use the .fbk as the extension of any filename used to save
the data.

Rather than use the back up program you can back up the single
data file directly.

To find the location of your data file click on the Network icon.

The resulting Database Connection screen displays the ip
address of the computer containing the data and the path within
that computer. The default data file name is Libsoft.gdb.

Note that 127.0.0.1 is a special address which refers to the
computer itself so in this case the data is installed locally on the
computer itself rather than a server or remote computer. If a
different number is used please refer to your IT staff to find out
which computer the data is located on.

To back up just copy and paste the data file to a flash drive or
another computer.
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Automatic Backups

The Backup Schedule allows you to choose from a wide range of
backup options. The general rule of backing up is to backup whatever
you cannot afford to lose. If you have a high circulation library you may
wish to backup during time blocks that circulation is slow. The backup
process is very fast. If you shut down LiBRARYSOFT at the end of the
day you may wish to use the option that backs up whenever
LiBRARYSOFT is closed.

The backup location is important. If you backup only onto your
computer it is of little help if the computer is stolen or if the hard drive
is destroyed by a power surge or corruption. You can use the browse
icon to find a location on your network or on a drive or memory stick to
backup onto.

It is important to rotate your backups, if a data file becomes corrupt
there is no point to have a backup of a corrupt file. Most networked
systems will automatically backup and archive data on the server but
it is best to confirm that this procedure is indeed in place with your IT
dept, otherwise periodically copy the backup or a copy of the actual
data file into a different location.

Backup files will have the extension .fbk

If you prefer to back up manually and not see the automatic backup
countdown screen please check the Manually checkbutton.

Note that our backup program is a simple generic program and may
be blocked by security or firewall restrictions. There are many
inexpensive third party programs that can easily back up files or a .bat
file may be used for backup.



© Copyright 2025       New Generation Technologies Inc.         All Rights Reserved.         LiBRARYSOFT is a registered trademark of New Generation Technologies Inc.

135

Restoring backed up data
To recover backed up data click Setup > Administration > Select
Restore Database.

To restore data from a backup click on the browse button to find
your backup. Backups will have the file extension .fbk

Once you have found the backup the default destination name
will appear. If you would like the name of the destination to
change to the new name entered click on the Restore to new
name checkbox.

Click on the Start button to begin the recovery
process. When the restore has ended click on the close button.

Note that Versions 10 and older of LiBRARYSOFT use .gdb files and
.gbk backup files. Version 11 & 12 uses .fdb and .fbk formats altho
you can use gdb files in which case the back up file will be .gbk.

Purging Data
At times you may wish to delete item, patron or historical data
This may be due to changes in patrons such as a semester system
or new school year. Removal of a range of items or historical data
that is too old and need needs to be backed up and then deleted.
You can request SQL commands from our staff for specific Purges
and Deletions of data.

The default selection is History. Historical data is the record of
who borrowed what over what period of time. It allows you to
view the borrowing activity of your collection so that you can cull
items that are never borrowed and increase your collection in the
areas of high traffic.

To delete a section of historical data enter the start and end dates
you wish to delete over. The format is year, month, day.

Click on the Delete button to proceed and the Close button when
complete.

The Hold Purge is similar to the Historical Purge in that a date
range is applied to specify the period over the purge will be
applied.
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Click on the pulldown and select Patron.

A new pulldown appears that allows you to select a range by
patron barcode or patron group. The barcode works by numerical
order and the group alphabetical.

Enter the range and click on the Delete button to proceed and
the Close button when complete.

To purge items click on the Pulldown and select Catalog. The only
option available is ibarcode.  Enter a numeric range of the items
you would like to delete.

Importing from other LiBRARYSOFT Libraries
Importing into the LiBRARYSOFT Database from other
LiBRARYSOFT Databases

Setup > Administration > Import Database

You may have two separate LiBRARYSOFT data files from two of
your libraries that you wish to merge or you may have data that
different people have entered on separate machines that you
wish to merge into one data file. Or you may be entering data or
editing material at home and would like to load this work into the
data at the library. Perhaps a few days have gone by so you cannot
just overwrite the data file as this would wipe out any circulation
activity that was done after you  loaded a copy of the file. The
way to get around this is to use the smart import option that will
only load in material that has been changed, as well as new
records. It will not overwrite any existing data.

Loading in data which has barcodes that do not exist in the other
database.

Step 1.
Move a copy of the other database onto the computer you would
like to load this second set of data into. Put it into the
LiBRARYSOFT folder (usually located in the program files folder of
C drive of your computer) providing that no file of the same name
is already there. If you are prompted to overwrite just click no
and put the file in another location that you can easily find.

Step 2.
Click on the Admin icon > Import > Interbase
as per the screen shots to the right.

Step 3.
Click on the Browse button and browse to the data file you have
just loaded onto this machine.
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Step 4.
Check the Catalog and Patron boxes if you are loading both sets of
data into the database. If you are only loading items check Catalog,
if you are only loading Patrons check Patrons. Check both if you
are loading both.

Step 5.
As the two databases have mutually exclusive barcodes for items
and patrons we can check "Replace all Fields" as there is no
possibility of overwriting existing data with the same barcodes.

Step 6.
As the "Replace all fields" option was chosen you can click Start,
the Update Key selection should be left on Barcode number on
both.

Depending upon the amount of data it may take a little while to
run through the loading process.

Loading in data which has barcodes that do exist in the other
database but you wish to overwrite with changes made to that
existing data plus perhaps add some new data which has been
entered.

Proceed as per the previous set of instructions. It will overwrite
existing data with the new information entered.

Loading in data which has barcodes that do exist in the other
database but you do not wish to overwrite with changes made
to that existing data plus perhaps add some new data which
has been entered.

Steps 1 to 4 are as per the previous page.

Step 5.
As you do not wish to overwrite the data with any changed
from the second data set check "Replace only Empty Fields".

This will only allow data to fill the empty fields records with the
same barcode number (this presumes that Barcode Number is
selected as the Catalog Update Key).

If you have records with Author , Title and Location data
then the data from the second database which may include
data such as subject, Edition, and Note field information will
be loaded in. Author Title and the fields Author, Title, Location
will be unchanged.

Updating Items Keyed by ISBN number
There may be situations where the other data has different
barcodes but the same ISBN number. This would be the case
where you are trying to load in the work done on another
database which has more information about some records but
the barcode numbers are totally different. In this case you would
check ISBN as the Catalog Update Key rather than Barcode Number.
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Updating Patrons Keyed by Name (patron name)
In a similar way you may have two database with patron names that
have different barcode numbers but you wish to update any missing
data keying by patron name. In this case you would select Name for
the Patron Update Key.

Importing data into the MS Sql Server version of
LiBRARYSOFT

The import option above is under the Admin icon of the MS SQL
version of LiBRARYSOFT and can be used to import data from the
Interbase version into the ms sql version.

Exporting Data from LiBRARYSOFT

The Export Module will be displayed within the Admin Icon Menu
if it has been purchased.

To Export check the option you wish to export to and click the
Export Button. Click on the Marc Tags button to specify what Marc
tags you would like to export to. Note that images are not
exported.

If you wish to manipulate data in excel and reload the changes
you can export to excel, implement the changes. Export from
excel to a Tab delimited file and import into librarysoft via the
Ongoing Text import option. Image data can be reloaded by using
the AutoCataloguing AutoFill option.

Cautions: AutoFill will only load images from items with isbn
numbers entered. If you copied an image in directly it may not be
the same as the one retrieved.
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One of the unique features of LiBRARYSOFT is that it provides SQL
(structured query language) access to your database. Such access
permits you to make changes immediately rather than emailing your
data into us.

Setup > Administration > Select SQL.

Please note that as a precaution you should always backup your data
file prior to running any SQL command. Some basic command sen-
tences can be seen by going to Help and searching for SQL. Do not
hesitate to email or call for assistance regarding the use of SQL
statements.

SQL access to your Library Data Library Bookstore Sales
Tools > Book Store
Some libraries allow items within the library to be sold at books sales
or on an ongoing basis to provide an extra source of funds. This can
provide revenue from items to be culled from the library collection. The
LiBRARYSOFT Bookstore Module can be used to sell used or new
items  as required.

The Bookstore screen is similar to the Circulation Checkout screen
and functions in much the same way.

Select or scan in a patron.
Search for or scan in an Item.
Select what Acquisitions Account and Category the funds resulting
from the sale should be applied to. You will need to set these up in
the Acquisitions Module prior to selling the items.

You can choose to delete the items sold from the Catalog or you can
allow them to remain (and perhaps be re-ordered) and have their
status displayed as Sold.

Receipts can be printed. The design and layout of the Receipt can be
changed by clicking on the Design button and altering the layout and
content as necessary.
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The basic idea of Inventory is that you can scan in items and
create a list of items that have not been scanned in and are not
checked out.

The Checkbox "Auto Check In Borrowed Items" can be checked if you
are certain that the items will be returned. The missing items reports
has an option to not select items that are checked out so the Auto
Check in option does not have to be used.

The option Checkbox "Inventory by ISBN numbers allows the
scanning process to be by ISBN rather than barcode. This is for items
that have not barcoded their library.

Inventory

Scanning in items is cumulative and need not be done all at once. It
can be done over a period of time depending upon the traffic of items
in and out of the Library.

Missing Items Report
The Missing Items Report can be run over all items or over a range of
items by a selected fields. The Report can be ordered and has a the
option to not list items that are checked out.

Lost and Purge
Be cautious with the Purge option as it will permanently delete the
missing items. Items can be marked in Item status with the Mark
option.

Reset Inventory
This clears the Barcodes that have been scanned in.
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Items can have their Status set to Lost or they can be Purged or
they can be purged if they have the Status of Lost.

The Status can be changed in a selective way. Checked out Items
can be eliminated from the range.

The Inventory can be cleared from the Inventory list completely
or by a Range.

Lost and Purge

Reset Inventory

Is used to manage the purchasing, receipts, and claims of Serial
publications such as magazines, newspapers and journals. These
can be automatically added to the main database as they are
received.

General Use

Steps to Entry of Serial Data:

1.Enter in Vendor information by clicking on the Vendor Menu
option.
2.Enter in publication information (after step 1 you have Vendors
within the Vendor pulldown).
3. The tabs beside publication apply to that particular
publication.
4.Going to issues and clicking on Auto Create will cause the
system to display issues of the publication and allow you to
define them as they arrive.
5. Routing lets you define which list of patrons should receive
the publication before it goes into general circulation.
6. The Claims option lets you generate notices for items that
were never received. These can be sent by regular mail or email.
7. The Reports menu will display lists of subscriptions received,
late, overdue, Vendor lists and other information.

Vendor Entry
In order to apply Claims you must enter Vendor information of
your publications first by clicking on the Vendor Menu. Click on
the Add button to get a blank screen. Enter the name of the
Vendor, your account number and the web address of the
Vendor. By clicking on the globe beside the entry your browser
will go to the address entered.  For each vendor you can enter
the Primary contact, Contact for Billing, Claims, Orders as well as
notes regarding the Vendor. Now when you click on the
Publication Tab you can pull down the relevant Vendor.

The Serials Module
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Publication Entry
Click on the Publication Tab. Note that the Tabs apply to the
publication.

Routing

You can view the current routing of a  publication by clicking on the
Routing tab.

Click on the Routing Menu option to change any listings.
Click on Add to add to the Route List for a publication.  To create a list
of patrons for each Route use the arrows to add to the list and change
the order within the list.

Claims

To set up claim processes for the publication enter the claim periods
per the expected date and other notices.
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To view the Claims click on the Claims menu. Select a button to
specify the claim information you would like to view.

Notice Content

Click on the Notice Text button to edit the content of the three types
of Notices.

Receiving Issues

Receiving is accessed from the Receiving Menu. It allows you to view
and delete received information.  The Issues tab permits you to add
and auto add issues to the received listing.

Colors

White indicates that the item has been received.

Blue indicates that the item has not been received yet.

Red shows that it has not been received and is overdue.
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Acquisitions Module
Is used to keep track of funds coming into the library and manage the
payment to book suppliers and vendors.  Items entered for purchase
can be added to the main library database as they are received.

Enter Payees

Click on the Add button to add a new vendor or funding source. By
clicking on the Tabs and clicking on Edit you can enter the billing, and
other contacts. Note that there is a "same as primary" button that will
save re-entering the same or similar information.

Enter Accounts

Click on the Add button to add a new account. Enter the account
name, a representative abbreviation, an opening date for the account,
the opening balance and a description of the account. After clicking on
OK this information will appear in the account screen.  To deposit to
an Account a Payee must be used. Payee's can also of course be
paid from an account.
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Transactions

Using the Tab buttons below you can make a payment, deposit or
Transfer funds. The result will appear in the list of Transactions for the
fund.

Categories

Define the nature of the expense or income. Clicking on one such as
Book (expense) displays the activity in this area.  Categories have a
pulldown in the Order entry screen.

Orders

The Order screen displays your orders and by color indicates if the
items have been received (white) or not received payment sent (blue).
Once paid the order cannot be edited.  To enter an order click on the
Add button.
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Entering Orders

Enter the order information regarding the item to be purchased. Select
the Account and Category that apply to the purchase of this item.

You have the option to add the Catalog information into the database
after it is received. Do not do this if you expect to receive MARC
records on diskette that describe the item.

Enter in the cost of the item and number of copies as well as any tax
requirements. Select from the pulldown the status of the item, the
options are Sent, Paid, Received.  Note that "Sent" in this context
means that you have sent the vendor a purchase order.  Enter Re-
ceived only after the item has been received in satisfactory condition.

Click on OK once you have finished entry.

Purchase Orders

Select the items you would like to create a PO for. Note the select
icon.  Click on the Print button to generate the order.

An example Purchase order is displayed below.

Reports

A number of reports are available from the Reports menu. They
include Order, Account, Category and Vendor reports. All of them can
be edited by clicking on the design icon.
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Reports

A number of reports are available from the Reports menu. They
include Order, Account, Category and Vendor reports. Each report
has an associated Select and Sort by Screen that allows you to
define the range of information to be displayed. Click on the Print
button to display the report.
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Reports

Category and Vendor reports. Both can be edited by clicking on the
design icon.
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Programs > Schedule

Choose a day and a time, select the Resource Type
and Name, and highlight the areas you would like to
reserve or click the Add button to define the period.

The Table view ( option at the bottom of the screen)
provides an alternate view.

The Scheduling Module
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Setting up Schedules

Enter Resource Types and Resource Names to go with a Resource
Type. For example the Transportation could apply to Buses, cars etc.
Within the library you can enter the various jobs or positions within
the library and match it to your staff.

The Table option allows you to see a spreadsheet view of the
scheduled items.
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Managing Textbooks with LiBRARYSOFT
TeXTBOOKSOFT is a way of using LiBRARYSOFT to manage
Textbooks. The system can be used to enter Text books,
duplicate them and check them out to students and faculty. Note
that licensing for LiBRARYSOFT does not automatically provide a
License for TeXTBOOKSOFT. The purchase of a license for
LiBRARYSOFT allows the library to be automated using
LiBRARYSOFT The purchase of TeXTBOOKSOFT allows all
textbooks used by the institution to be automated. This does not
apply to institutions with multiple campuses. It only applies to
the campus of the institution purchasing the product.

The Catalog Module is used to enter textbooks. The repeat
button allows you to duplicate items which is useful when
working with textbooks. Even textbooks in pdf format can easily
added to the library. PDF and Sound items can be downloaded by
students using OPACInternet. Websites related to a textbook can
be stored and retrieved by students or staff. The Textstore field
can store up to 300 pages of text. OLE links can be used to link to
Work, Powerpoint, Access and other OLE type programs that are
related to the textbook or any record stored in the database. The
textbook information can be loaded using the MARC module or
AutoCataloguing.

The Circulation Module can check textbooks out to staff who in
turn can check items out to students or textbooks can be checked
out directly to students. This can done using a barcode scanner or
typing in the barcode of the student and the textbooks borrowed
by the student. The Locking Self-Circulation/OPAC Module can be
by Staff to check items out to students without the possibility of
accidently damaging or removing data from the database. It can
eve be used by students. Students can be added to the database
from school administrative systems by loading into the
LiBRARYSOFT excel template file or comma delimited files.

The Report Module has existing report and even includes a
report generator that can be used to create a report over any
range of fields, in any order presented in any way.

LiBRARYMaP can be used to display the location of the textbooks
with a campus and within the room and shelf and the position on
the shelf where they are located.

LiBRARYSOFT can print Barcode labels for the textbooks and
students or pre-printed labels can be used. The school may
already have existing barcode values for the students which can
be used.

The OPACInternet Module can be used with the school server or
district server so that instructors and administrative staff can
check who has what textbooks. When students leave these
textbooks can be checked back in. It can be used to across a
network or the internet.

The Acquisitions Module can be used to manage accounts if
different funding is used to manage the acquisition and funding
of textbooks and supplies.

The Scheduling Module can be used to schedule access to
resources such as specialized textbooks, AV equipment or other
material that requires reservation.
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Note that licensing for LiBRARYSOFT does not automatically provide a
License for TeXTBOOKSOFT. The purchase of a license for LiBRARYSOFT
allows the library to be automated using LiBRARYSOFT The purchase of
TeXTBOOKSOFT allows all textbooks used by the institution to be automated.
This does not apply to institutions with multiple campuses, it only applies to
the campus of the institution purchasing the product.

LiBRARYSOFT™ License Agreement

COPYRIGHT

The Product LiBRARYSOFT, defined as this Software and all other printed Material
accompanying the Software, including the trademark of LiBRARYSOFT  is owned by
New Generation Technologies Inc. and is protected by United States and International
Copyright Laws and Treaty provisions.  You must treat the Product like any other
copyrighted material, except to the extent that this License provides to the contrary.
Your right to use the materials terminates automatically if you violate any part of this
License.  In the event of termination, you must immediately destroy all copies of the
material or return them to New Generation Technologies Inc.

MULTIPLE LICENSES

You are granted a single license for use of the library within the single building or
dwelling that contains the library that purchased a single copy of LiBRARYSOFT™.
The library is defined to be a single collection of data.  The library must use one single
data file.  This data files may contain the data of many libraries but it must exist in a
single file, the library.gdb file. This license only applies to the single building containing
the library even if the purchasing institution or company has multiple buildings or
dwellings. There is no restriction in the number  of workstations using the OPAC module
or the OPAC internet or intranet version. Both the regular OPAC module and internet/
intranet version of OPAC may be used on a wide area network for distribution of
information within other buildings not containing the library.  OPAC is restricted in that
it can only access LiBRARYSOFT data.  It cannot be used with any other data source.
This applies to all version of OPAC.   No other modules other than OPAC are licensed
for use outside of the single dwelling or building containing the library.

SUPPORT POLICY

New Generation Technologies Inc. intends to provide quality support to bona fide
licensees who respect our license agreement.  Support, however, will not be provided
unless the licensee can provide a valid registration number.

LICENSE GRANT

This License determines your right with respect to the Software.  You may:

 Use one copy of the Software on a single computer, provided that the  Software
is in use on only one computer at a time, the OPAC module can be used on
any number of computers using your data only within your building or
dwelling.  If you have multiple Licenses for the Software, then at any time you
may use as many copies of the Software as you have Licenses.  Installing a
copy of the Software on a network server where it is resident for the sole
purpose of distributing it to other computers is not “use” that requires an
additional License.

 After written notification to New Generation Technologies Inc., transfer the
entire Product on a permanent basis to another person or entity, provided
you retain no copies of the Product and the transferee agrees to the terms of
this License.

LICENSE RESTRICTIONS

You may not:

 Copy the documentation.

 Translate the Software.

 Merge the Software with another program or modify the Software, except as
may be specifically described in the Documentation.

 Reverse-engineer, disassemble, decompile, or make any attempt to discover
the source code of the Software.

 Sublicense, rent, or lease any portion of the Product.

 Sell or rent a previous version of the Software for which you have acquired an
upgrade for.

 Use any of the LiBRARYSOFT modules with any data source other than
LiBRARYSOFT provided.

 Distribute copies of the software including the OPAC module.

LiBRARYSOFT Licensing
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LIMITED WARRANTY

New Generation Technologies Inc. warrants that for a period of 90 days from the
receipt of the Software: (1) the media on which the Software is distributed will be free
from defects in materials and workmanship. Any written or oral information or advice
given by New Generation Technologies Inc. dealers, distributors, agents, or employees
will in no way increase the scope of this warranty.  If the Product fails to comply with
the warranty set forth above, New Generation Technologies Inc.’s entire liability and
your exclusive remedy will be replacement of the CD ROMs.  Any replacement Product
will be warranted for the remainder of the original 90-day warranty period or for 30
days from the date you received the replacement, whichever is longer.  These remedies
are not available outside of the United States and Canada.  For countries other than
the U.S. and Canada New Generation will email replacement files.

NEW GENERATION TECHNOLOGIES INC. DISCLAIMS ALL OTHER
WARRANTIES, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT
LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE PRODUCT.  THIS
LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS.  YOU MAY HAVE
OTHERS, WHICH VARY FROM STATE TO STATE.

LIMITATION OF LIABILITY

Neither New Generation Technologies Inc. nor anyone else who has been involved in
the creation, production, or distribution of the Product shall be liable for any direct,
incidental, or consequential damages, such as but not limited to, loss of anticipated
profits or benefits, resulting from the use of the Product or as the result of a breach of
warranty.  Some states do not allow the exclusion or limitation of direct, incidental, or
consequential damages so the above limitation may not apply to you.

U.S. GOVERNMENT RESTRICTED RIGHTS

The product is provided with RESTRICTED RIGHTS.  Use, duplication, or disclosure
by the U.S. government is subject to restrictions set forth in subparagraph (c)(1)(ii) of
the Rights in Technical Data and Computer Software clause at DFARS, 48 C.F.R. §
252.227-7013, or subparagraphs (c)(1) and (2) of the Commercial Computer Software
– Restricted Rights clause at FAR, 48 C.F.R. .§ 52.227-19, as applicable.
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